fix initial root dirs creation when empty cvs dirs are not pruned
authorNicolas Thill <nico@openwrt.org>
Thu, 17 Feb 2005 06:36:48 +0000 (06:36 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 17 Feb 2005 06:36:48 +0000 (06:36 +0000)
SVN-Revision: 247

openwrt/Makefile

index 0fa90fb40d7aa3a0f4ae096cc45c189a94158c80..b240492b897fa2bb2cd76871633c5a28ca031443 100644 (file)
@@ -107,7 +107,7 @@ $(STAGING_DIR):
 $(TARGET_DIR):
        @mkdir -p $(TARGET_DIR)
        cp -a target/default/target_skeleton/* $(TARGET_DIR)/
-       mkdir $(TARGET_DIR)/{proc,dev,jffs,tmp,usr/sbin}
+       mkdir -p $(TARGET_DIR)/{proc,dev,jffs,tmp,usr/sbin}
        chmod 1777 $(TARGET_DIR)/tmp
        -find $(TARGET_DIR) -type d -name CVS -exec rm -rf {} \; > /dev/null 2>&1