mosh: Fix compilation with libcxx
authorRosen Penev <rosenp@gmail.com>
Sat, 14 Dec 2019 05:54:01 +0000 (21:54 -0800)
committerRosen Penev <rosenp@gmail.com>
Sat, 14 Dec 2019 08:18:53 +0000 (00:18 -0800)
Partial backport of upstream patch.``

Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/mosh/Makefile
net/mosh/patches/020-std.patch [new file with mode: 0644]

index c22041f166c02776325798f7824d8e2194441fa5..b4a666b87240f987c64194e0d1d305c33251a336 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mosh
 PKG_VERSION:=1.3.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://mosh.org/
diff --git a/net/mosh/patches/020-std.patch b/net/mosh/patches/020-std.patch
new file mode 100644 (file)
index 0000000..06ad284
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/src/network/network.cc
++++ b/src/network/network.cc
+@@ -60,7 +60,6 @@
+ #define AI_NUMERICSERV 0
+ #endif
+-using namespace std;
+ using namespace Network;
+ using namespace Crypto;