shadowsocks-libev: fix compilation with GCC10
authorRosen Penev <rosenp@gmail.com>
Fri, 3 Jul 2020 00:08:56 +0000 (17:08 -0700)
committerYousong Zhou <yszhou4tech@gmail.com>
Fri, 3 Jul 2020 03:24:52 +0000 (11:24 +0800)
Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/shadowsocks-libev/Makefile
net/shadowsocks-libev/patches/010-gcc10.patch [new file with mode: 0644]

index 85c088550aab1b8a65fd03ce63fd70cda21320e7..d7a6f784458a259da68e05930236fd31c7ca4715 100644 (file)
@@ -14,7 +14,7 @@ include $(TOPDIR)/rules.mk
 #
 PKG_NAME:=shadowsocks-libev
 PKG_VERSION:=3.3.4
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/shadowsocks/shadowsocks-libev/releases/download/v$(PKG_VERSION)
diff --git a/net/shadowsocks-libev/patches/010-gcc10.patch b/net/shadowsocks-libev/patches/010-gcc10.patch
new file mode 100644 (file)
index 0000000..1049fc2
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/src/http.h
++++ b/src/http.h
+@@ -29,6 +29,6 @@
+ #include <stdio.h>
+ #include "protocol.h"
+-const protocol_t *const http_protocol;
++extern const protocol_t *const http_protocol;
+ #endif
+--- a/src/tls.h
++++ b/src/tls.h
+@@ -28,6 +28,6 @@
+ #include "protocol.h"
+-const protocol_t *const tls_protocol;
++extern const protocol_t *const tls_protocol;
+ #endif