Merge pull request #14894 from cotequeiroz/php7-pecl-imagik
authorEneas U de Queiroz <cotequeiroz@gmail.com>
Fri, 26 Feb 2021 16:20:27 +0000 (13:20 -0300)
committerGitHub <noreply@github.com>
Fri, 26 Feb 2021 16:20:27 +0000 (13:20 -0300)
php7: adjust build with QUILT

lang/php7/Makefile
lang/php7/pecl.mk

index 0f49819f983fa4158ee4c67d25e3793709d0b842..96268e5644b0b3f079d24689c0ec9e1216e16279 100644 (file)
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=php
 PKG_VERSION:=7.4.15
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
 PKG_LICENSE:=PHP-3.01
@@ -530,7 +530,12 @@ endef
 
 define Build/Prepare
        $(call Build/Prepare/Default)
-       ( cd $(PKG_BUILD_DIR); touch configure.ac; ./buildconf --force )
+       $(if $(QUILT),,( cd $(PKG_BUILD_DIR); touch configure.ac; ./buildconf --force ))
+endef
+
+define Build/Configure
+       $(if $(QUILT),( cd $(PKG_BUILD_DIR); touch configure.ac; ./buildconf --force ))
+       $(call Build/Configure/Default)
 endef
 
 define Build/InstallDev
index d85e8d139917195b7be250eb5b2cf4d64a5f1ab5..faa8b090fee94a623820c03254281c33132c0d13 100644 (file)
@@ -16,6 +16,11 @@ define Build/Prepare
        $(if $(QUILT),,( cd $(PKG_BUILD_DIR); $(STAGING_DIR)/usr/bin/phpize7 ))
 endef
 
+define Build/Configure
+       $(if $(QUILT),( cd $(PKG_BUILD_DIR); $(STAGING_DIR)/usr/bin/phpize7 ))
+       $(Build/Configure/Default)
+endef
+
 CONFIGURE_VARS+= \
        ac_cv_c_bigendian_php=$(if $(CONFIG_BIG_ENDIAN),yes,no)