tailscale: enable autodect of fw type
authorTyler Young <git@yfh.addy.io>
Mon, 28 Aug 2023 00:58:10 +0000 (20:58 -0400)
committerTianling Shen <cnsztl@gmail.com>
Mon, 28 Aug 2023 13:59:55 +0000 (21:59 +0800)
Signed-off-by: Tyler Young <git@yfh.addy.io>
net/tailscale/Makefile
net/tailscale/files/tailscale.init

index 8cd236efb1945a32d1973d81f6d194a52dba196e..48152ec908e98c90107fc021de684c213bc59dea 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tailscale
 PKG_VERSION:=1.48.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/tailscale/tailscale/tar.gz/v$(PKG_VERSION)?
index 6548fa220018d277e2fd9c41b1c3aa543e14179c..7d5f52134c344d26bd886d3a73c5e260434bfbd0 100644 (file)
@@ -23,6 +23,9 @@ start_service() {
   procd_open_instance
   procd_set_param command /usr/sbin/tailscaled
 
+  # starting with v1.48.1 ENV variable is required to enable autodetection of iptables / nftables
+  procd_set_param env TS_DEBUG_FIREWALL_MODE=auto
+
   # Set the port to listen on for incoming VPN packets.
   # Remote nodes will automatically be informed about the new port number,
   # but you might want to configure this in order to set external firewall