projects
/
openwrt
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
d1000f8
)
kernel: ext4: Add missing kmod-crypto-crc32c dependency
author
daniel
<daniel@dd-wrt.com>
Mon, 10 Oct 2016 15:56:16 +0000
(17:56 +0200)
committer
Felix Fietkau
<nbd@nbd.name>
Thu, 13 Oct 2016 15:04:28 +0000
(17:04 +0200)
This fixes the following error when mounting a ext4 filesystem
----
[ 166.240000] EXT4-fs (sda1): Cannot load crc32c driver.
----
Signed-off-by: Daniel Danzberger <daniel@dd-wrt.com>
package/kernel/linux/modules/fs.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/fs.mk
b/package/kernel/linux/modules/fs.mk
index fbac68bc00066e2475668dd62e465f398fc02496..ce2408cdc4761a6f77486665d1ba41887d5d508f 100644
(file)
--- a/
package/kernel/linux/modules/fs.mk
+++ b/
package/kernel/linux/modules/fs.mk
@@
-177,7
+177,8
@@
define KernelPackage/fs-ext4
TITLE:=EXT4 filesystem support
DEPENDS := \
+kmod-lib-crc16 \
- +kmod-crypto-hash
+ +kmod-crypto-hash \
+ +kmod-crypto-crc32c
KCONFIG:= \
CONFIG_EXT4_FS \
CONFIG_EXT4_ENCRYPTION=n \