dahdi-linux: bump to version 3.1.0 509/head
authorSebastian Kemper <sebastian_ml@gmx.net>
Thu, 19 Mar 2020 17:39:19 +0000 (18:39 +0100)
committerSebastian Kemper <sebastian_ml@gmx.net>
Thu, 19 Mar 2020 17:39:22 +0000 (18:39 +0100)
This commit provides compatibility with kernel 5.4.

Except for the version bump this commit updates the HFC-S PCI driver to
not rely on the macro "dahdi_pci_module" anymore, because it has been
removed upstream in commit 4af6f69.

Also, a patch is added that makes the include of "<linux/pci-aspm.h>"
conditional on the kernel version, because starting with kernel 5.4 this
header has been removed and its contents merged into "pci.h".

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
libs/dahdi-linux/Makefile
libs/dahdi-linux/patches/100-add-support-for-hfc-s-pci.patch
libs/dahdi-linux/patches/120-pci-header.patch [new file with mode: 0644]

index dd8cda4505fbd7b2693447d8918a4e7e227576e4..e648217a0cf4fa8058572d77aea3983f4b037831 100644 (file)
@@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=dahdi-linux
-PKG_VERSION:=3.0.0
+PKG_VERSION:=3.1.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://downloads.asterisk.org/pub/telephony/dahdi-linux/releases
-PKG_HASH:=02a8a680d20a3e243f37259edc3554ab9a488595a28562c45c33da3792d12caa
+PKG_HASH:=db5b758437d066a7edad34b54313f08a4ccdde28373492986b72c798e8561b4d
 
 PKG_LICENSE:=GPL-2.0
 PKG_LICENSE_FILES:=LICENSE
index b8418ccc3935508bd4d0f38b5470aefa3edad575..4e40f9495f71801563cb2827435293c586454707 100644 (file)
 +      hfc_proc_dahdi_hfcs_dir = proc_mkdir(hfc_DRIVER_NAME, proc_root_driver);
 +#endif
 +
-+      ret = dahdi_pci_module(&hfc_driver);
++      ret = pci_register_driver(&hfc_driver);
 +      return ret;
 +}
 +
diff --git a/libs/dahdi-linux/patches/120-pci-header.patch b/libs/dahdi-linux/patches/120-pci-header.patch
new file mode 100644 (file)
index 0000000..9e2245c
--- /dev/null
@@ -0,0 +1,13 @@
+--- a/include/dahdi/kernel.h
++++ b/include/dahdi/kernel.h
+@@ -59,8 +59,10 @@
+ #include <linux/poll.h>
+ #ifdef CONFIG_PCI
++#if LINUX_VERSION_CODE < KERNEL_VERSION(5,4,0)
+ #include <linux/pci-aspm.h>
+ #endif
++#endif
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 29)
+ #define HAVE_NET_DEVICE_OPS