libglog: Add gflags a dependency for libglog 7877/head
authorAmol Bhave <ambhave@fb.com>
Sat, 5 Jan 2019 04:44:54 +0000 (20:44 -0800)
committerAmol Bhave <ambhave@fb.com>
Tue, 30 Apr 2019 01:32:48 +0000 (18:32 -0700)
Depends on PR #7098

With gflags available, glog's compilation behaves differently and
includes gflags specific code. This code allows customizing logging in
programs that use glog, using command command line parameters.

Compile tested: openwrt-18.06 for ipq40xx, ipq806x, x86 and ar71xx
Run tested: Tested on devices running on the above architectures.

Signed-off-by: Amol Bhave <ambhave@fb.com>
libs/libglog/Makefile

index dcaab6afb6193e4f8b3646d6f897351c85fe31ba..928f4829777247ba54fa97c4aa79343713c654a3 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=glog
 PKG_VERSION:=0.4.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/google/glog/tar.gz/v$(PKG_VERSION)?
@@ -16,13 +16,15 @@ PKG_FIXUP:=autoreconf
 PKG_BUILD_PARALLEL:=1
 PKG_INSTALL:=1
 
+PKG_BUILD_DEPENDS:=libgflags
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/glog
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=C++ implementation of the Google logging module
-  DEPENDS:= +libstdcpp +libpthread
+  DEPENDS:= +libstdcpp +libpthread +gflags
   URL:=https://github.com/google/glog
   MAINTAINER:=Amir Sabbaghi <amir@pichak.co>
 endef