wifidog: fix compilation with more recent wolfssl
authorRosen Penev <rosenp@gmail.com>
Mon, 18 Jul 2022 22:16:15 +0000 (15:16 -0700)
committerRosen Penev <rosenp@gmail.com>
Wed, 20 Jul 2022 04:19:04 +0000 (21:19 -0700)
Needs an extra header. pthread.h is also no longer implicitly included.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/wifidog/Makefile
net/wifidog/patches/030-wolfssl-options.patch [new file with mode: 0644]

index 07cdbfd7df341468eaffc4e3b8521e8493a85733..900d8a6482185c900976b0ae8448e354591ee55f 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wifidog
 PKG_VERSION:=1.3.0
-PKG_RELEASE:=6
+PKG_RELEASE:=7
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/wifidog/wifidog-gateway
diff --git a/net/wifidog/patches/030-wolfssl-options.patch b/net/wifidog/patches/030-wolfssl-options.patch
new file mode 100644 (file)
index 0000000..3be051a
--- /dev/null
@@ -0,0 +1,18 @@
+--- a/src/simple_http.c
++++ b/src/simple_http.c
+@@ -28,6 +28,7 @@
+ #include <arpa/inet.h>
+ #include <errno.h>
+ #include <unistd.h>
++#include <pthread.h>
+ #include <string.h>
+ #include <syslog.h>
+@@ -37,6 +38,7 @@
+ #include "pstring.h"
+ #ifdef USE_CYASSL
++#include <cyassl/options.h>
+ #include <cyassl/ssl.h>
+ #include "conf.h"
+ /* For CYASSL_MAX_ERROR_SZ */