vim: variants conflict with each other
authorKarel Kočí <cynerd@email.cz>
Mon, 22 Aug 2022 12:31:21 +0000 (14:31 +0200)
committerRosen Penev <rosenp@gmail.com>
Wed, 24 Aug 2022 04:17:08 +0000 (21:17 -0700)
This adds conflicts between the variants,
because they provide the same files, and it should not be
possible to install them side by side. Otherwise, it might happen that
half files would be from one variant and the other half from the
other.

Also, adds provides as if you request to install ``vim`` and
``vim-full``, then the request could be satisfied even they collide,
because ``vim-full`` provides ``vim`` package.

Signed-off-by: Karel Kočí <cynerd@email.cz>
Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
[add commit message]

utils/vim/Makefile

index d093c032fbc4c52030826a52e8273b41ed90028f..565f0f0efaae189af839b06d274be27c4faa32cc 100644 (file)
@@ -41,12 +41,16 @@ endef
 define Package/vim-full
   $(call Package/vim/Default)
   TITLE+= (Normal)
+  PROVIDES:=vim
+  CONFLICTS:=vim
 endef
 
 
 define Package/vim-fuller
   $(call Package/vim/Default)
   TITLE+= (Big)
+  PROVIDES:=vim vim-full
+  CONFLICTS:=vim vim-full
 endef
 
 define Package/vim-runtime