xmltodict: Update to 0.13.0, rename source package 22039/head
authorJeffery To <jeffery.to@gmail.com>
Mon, 4 Sep 2023 21:56:22 +0000 (05:56 +0800)
committerJeffery To <jeffery.to@gmail.com>
Mon, 4 Sep 2023 21:57:23 +0000 (05:57 +0800)
This renames the source package to python-xmltodict to match other
Python packages.

This also updates the list of dependencies.

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
lang/python/python-xmltodict/Makefile [new file with mode: 0644]
lang/python/xmltodict/Makefile [deleted file]

diff --git a/lang/python/python-xmltodict/Makefile b/lang/python/python-xmltodict/Makefile
new file mode 100644 (file)
index 0000000..87b841f
--- /dev/null
@@ -0,0 +1,41 @@
+#
+# Copyright (C) 2019 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-xmltodict
+PKG_VERSION:=0.13.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=xmltodict
+PKG_HASH:=341595a488e3e01a85a9d8911d8912fd922ede5fecc4dce437eb4b6c8d037e56
+
+PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-xmltodict
+  SECTION:=lang
+  CATEGORY:=Languages
+  SUBMENU:=Python
+  TITLE:=Work with XML like JSON
+  URL:=https://github.com/martinblech/xmltodict
+  DEPENDS:=+python3-light +python3-xml
+endef
+
+define Package/python3-xmltodict/description
+xmltodict is a Python module that makes working with XML feel like you
+are working with JSON.
+endef
+
+$(eval $(call Py3Package,python3-xmltodict))
+$(eval $(call BuildPackage,python3-xmltodict))
+$(eval $(call BuildPackage,python3-xmltodict-src))
diff --git a/lang/python/xmltodict/Makefile b/lang/python/xmltodict/Makefile
deleted file mode 100644 (file)
index 44cf4cd..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-#
-# Copyright (C) 2019 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=python-xmltodict
-PKG_VERSION:=0.12.0
-PKG_RELEASE:=2
-
-PYPI_NAME:=xmltodict
-PKG_HASH:=50d8c638ed7ecb88d90561beedbf720c9b4e851a9fa6c47ebd64e99d166d8a21
-
-PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com>
-PKG_LICENSE:=MIT
-PKG_LICENSE_FILES:=LICENSE
-
-include ../pypi.mk
-include $(INCLUDE_DIR)/package.mk
-include ../python3-package.mk
-
-define Package/python3-xmltodict
-  SECTION:=lang
-  CATEGORY:=Languages
-  SUBMENU:=Python
-  TITLE:=Work with XML like JSON
-  URL:=https://github.com/martinblech/xmltodict
-  DEPENDS:= \
-       +python3-light \
-       +python3-xml \
-       +python3-urllib
-endef
-
-define Package/python3-xmltodict/description
-  xmltodict is a Python module that makes working with XML feel like you are working with JSON.
-endef
-
-$(eval $(call Py3Package,python3-xmltodict))
-$(eval $(call BuildPackage,python3-xmltodict))
-$(eval $(call BuildPackage,python3-xmltodict-src))