libfolly: Pass -DBoost_NO_BOOST_CMAKE
authorRosen Penev <rosenp@gmail.com>
Thu, 12 Sep 2019 21:33:14 +0000 (14:33 -0700)
committerRosen Penev <rosenp@gmail.com>
Thu, 12 Sep 2019 21:33:14 +0000 (14:33 -0700)
It seems the new CMake update broke boost again.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
libs/libfolly/Makefile

index 1dd7cb4a5f025ccf227b2dba8f0f424019745249..8a0b87f7be9d5cd7a451192d4ced1e8342ee0e32 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libfolly
 PKG_VERSION:=2019.09.09.00
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/facebook/folly/tar.gz/v$(PKG_VERSION)?
@@ -48,7 +48,8 @@ CMAKE_OPTIONS += \
        -DFOLLY_HAVE_WCHAR_SUPPORT_EXITCODE__TRYRUN_OUTPUT=OFF \
        -DHAVE_VSNPRINTF_ERRORS_EXITCODE=OFF \
        -DHAVE_VSNPRINTF_ERRORS_EXITCODE__TRYRUN_OUTPUT=OFF \
-       -DBUILD_SHARED_LIBS=ON
+       -DBUILD_SHARED_LIBS=ON \
+       -DBoost_NO_BOOST_CMAKE=ON
 
 TARGET_CXXFLAGS += -ffunction-sections -fdata-sections -flto
 TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed