libssh2: remove $(FPIC) from TARGET_CFLAGS
authorSebastian Kemper <sebastian_ml@gmx.net>
Sat, 24 Feb 2018 10:45:16 +0000 (11:45 +0100)
committerSebastian Kemper <sebastian_ml@gmx.net>
Sat, 24 Feb 2018 10:45:18 +0000 (11:45 +0100)
libssh2 already makes sure that the compiler emits position-independent
code. Adding $(FPIC) makes no difference. In addition the libssh2 build
system puts its own flag behind the CFLAGS, overriding whatever was set
before.

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
libs/libssh2/Makefile

index cdb133cb5f17d4bc6876e7ee4a3c3b18c0cca2d5..9971659a2c5f258e15d78ff6d2797a6ed7c84f5e 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libssh2
 PKG_VERSION:=1.8.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://www.libssh2.org/download
@@ -41,8 +41,6 @@ define Package/libssh2/config
        source "$(SOURCE)/Config.in"
 endef
 
-TARGET_CFLAGS += $(FPIC)
-
 CONFIGURE_ARGS += \
        --disable-examples-build \
        --disable-silent-rules \