libsoxr: initial commit 246/head
authorMike Brady <mikebrady@eircom.net>
Mon, 25 Aug 2014 15:31:11 +0000 (16:31 +0100)
committerMike Brady <mikebrady@eircom.net>
Mon, 25 Aug 2014 15:31:11 +0000 (16:31 +0100)
Signed-off-by: Mike Brady <mikebrady@eircom.net>
libs/libsoxr/Makefile [new file with mode: 0644]
libs/libsoxr/files/configure [new file with mode: 0755]

diff --git a/libs/libsoxr/Makefile b/libs/libsoxr/Makefile
new file mode 100644 (file)
index 0000000..03ad713
--- /dev/null
@@ -0,0 +1,62 @@
+#
+# Copyright (C) 2014 OpenWrt.org  
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+# updated to work with latest source from abrasive
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libsoxr
+PKG_VERSION:=0.1.1
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=git://git.code.sf.net/p/soxr/code
+PKG_SOURCE_VERSION:=HEAD
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
+PKG_LICENSE:=LGPL-2.0
+
+PKG_FIXUP:=libtool
+PKG_REMOVE_FILES:=autogen.sh
+
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Build/Configure
+       $(CP) ./files/* $(PKG_BUILD_DIR)/
+       $(call Build/Configure/Default, )
+endef
+
+define Package/libsoxr
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=The SoX Resampler library
+  URL:=http://sourceforge.net/projects/soxr/
+  MAINTAINER:=Mike Brady <mikebrady@eircom.net>
+  DEPENDS:= +libpthread
+endef
+
+define Package/libsoxr/description
+  The SoX Resampler library
+  High quality, one-dimensional sample-rate conversion library
+endef
+
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_BUILD_DIR)/src/soxr.h $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/src/*.a $(1)/usr/lib/
+endef
+
+define Package/libsoxr/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/src/*.a $(1)/usr/lib/
+endef
+
+
+$(eval $(call BuildPackage,libsoxr))
diff --git a/libs/libsoxr/files/configure b/libs/libsoxr/files/configure
new file mode 100755 (executable)
index 0000000..0cf7857
--- /dev/null
@@ -0,0 +1 @@
+cmake -DBUILD_SHARED_LIBS=OFF -DBUILD_TESTS=0 -DBUILD_EXAMPLES=0 .