ovn: bump to 22.03.5
authorYousong Zhou <yszhou4tech@gmail.com>
Wed, 21 Feb 2024 08:41:19 +0000 (08:41 +0000)
committerYousong Zhou <yszhou4tech@gmail.com>
Thu, 22 Feb 2024 01:31:44 +0000 (09:31 +0800)
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
net/ovn/Makefile
net/ovn/patches/0002-build-skip-tests-and-docs.patch
net/ovn/patches/0004-fix-use-of-possible-uninitialized-var.patch

index 999986f93a78b3c5ca0abf44de2d10e623dd5423..186fb9596e701c1b3df53c39f8eb1cf2ef5baf52 100644 (file)
@@ -9,13 +9,13 @@ include $(INCLUDE_DIR)/kernel.mk
 include ../openvswitch/openvswitch.mk
 
 PKG_NAME:=ovn
-PKG_VERSION:=22.03.0
+PKG_VERSION:=22.03.5
 PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/ovn-org/ovn.git
 PKG_SOURCE_VERSION:=v$(PKG_VERSION)
-PKG_MIRROR_HASH:=eb494796a7a21e7c1ba5b3f60c037385eb5f0c33007ebc627437f36187f860fe
+PKG_MIRROR_HASH:=2fce32762c4f8f21ba10f2d41924188cd995bea56eb9a09a7a119b15b9c60224
 
 PKG_LICENSE:=Apache-2.0
 PKG_LICENSE_FILES:=LICENSE
index 12ef25de0b51aed1b56c70fbee79a63b74f44c0f..4d651d17a5ae2a96e751fbb64e91de2eb2ebd7f8 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
 
 --- a/Makefile.am
 +++ b/Makefile.am
-@@ -483,11 +483,9 @@ dist-docs:
+@@ -478,11 +478,9 @@ dist-docs:
  
  
  include automake.mk
index 21b90ec10bfc5e2688300a8df8aa9dddf1af4016..258f8e607288f408d761c72f8ea109909f2efc5a 100644 (file)
@@ -10,7 +10,7 @@ ic/ovn-ic.c:430:40: note: 'ls' was declared here
 
 --- a/ic/ovn-ic.c
 +++ b/ic/ovn-ic.c
-@@ -427,7 +427,7 @@ find_ts_in_nb(struct ic_context *ctx, ch
+@@ -433,7 +433,7 @@ find_ts_in_nb(struct ic_context *ctx, ch
          nbrec_logical_switch_index_init_row(ctx->nbrec_ls_by_name);
      nbrec_logical_switch_index_set_name(key, ts_name);