jh71x0: vf1: add AMPAK wifi support
authorZoltan HERPAI <wigyori@uid0.hu>
Fri, 11 Aug 2023 09:56:24 +0000 (11:56 +0200)
committerZoltan HERPAI <wigyori@uid0.hu>
Fri, 11 Aug 2023 09:56:24 +0000 (11:56 +0200)
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
target/linux/jh71x0/base-files/lib/firmware/brcm/brcmfmac43430-sdio.txt [new file with mode: 0644]
target/linux/jh71x0/base-files/lib/firmware/brcm/brcmfmac43430a0-sdio.txt [new symlink]
target/linux/jh71x0/image/Makefile

diff --git a/target/linux/jh71x0/base-files/lib/firmware/brcm/brcmfmac43430-sdio.txt b/target/linux/jh71x0/base-files/lib/firmware/brcm/brcmfmac43430-sdio.txt
new file mode 100644 (file)
index 0000000..9baa5c3
--- /dev/null
@@ -0,0 +1,53 @@
+#AP6212_NVRAM_V1.0_20140603
+# 2.4 GHz, 20 MHz BW mode
+
+# The following parameter values are just placeholders, need to be updated.
+manfid=0x2d0
+prodid=0x0726
+vendid=0x14e4
+devid=0x43e2
+boardtype=0x0726
+boardrev=0x1101
+boardnum=22
+macaddr=00:90:4c:c5:12:38
+sromrev=11
+boardflags=0x00404201
+xtalfreq=26000
+nocrc=1
+ag0=255
+aa2g=1
+ccode=ALL
+
+pa0itssit=0x20
+extpagain2g=0
+
+#PA parameters for 2.4GHz, measured at CHIP OUTPUT
+pa2ga0=-168,7161,-820
+AvVmid_c0=0x0,0xc8
+cckpwroffset0=5
+
+# PPR params
+maxp2ga0=90
+txpwrbckof=6
+cckbw202gpo=0x5555
+legofdmbw202gpo=0x77777777
+mcsbw202gpo=0xaaaaaaaa
+
+# OFDM IIR :
+ofdmdigfilttype=7
+# PAPD mode:
+papdmode=2
+
+il0macaddr=00:90:4c:c5:12:38
+wl0id=0x431b
+
+#OOB parameters
+hostwake=0x40
+hostrdy=0x41
+usbrdy=0x03
+usbrdydelay=100
+deadman_to=0xffffffff
+# muxenab: 0x1 for UART enable, 0x10 for Host awake
+muxenab=0x10
+# CLDO PWM voltage settings - 0x4 - 1.1 volt
+#cldo_pwm=0x4
diff --git a/target/linux/jh71x0/base-files/lib/firmware/brcm/brcmfmac43430a0-sdio.txt b/target/linux/jh71x0/base-files/lib/firmware/brcm/brcmfmac43430a0-sdio.txt
new file mode 120000 (symlink)
index 0000000..2ed6689
--- /dev/null
@@ -0,0 +1 @@
+brcmfmac43430-sdio.txt
\ No newline at end of file
index 862e298ab4f2e153d765034eac3dea8dcda74654..cbe0017edd80faa06990efd622cb700afec37517 100644 (file)
@@ -77,6 +77,7 @@ define Device/visionfive-v1
   DEVICE_VENDOR := StarFive
   DEVICE_MODEL := VisionFive v1
   DEVICE_DTS := starfive/jh7100-starfive-visionfive-v1
+  DEVICE_PACKAGES := kmod-eeprom-at24 kmod-brcmfmac cypress-firmware-43430-sdio
 endef
 TARGET_DEVICES += visionfive-v1