libgpiod: add missing kernel build options via KCONFIG 20165/head
authorFlorian Eckert <fe@dev.tdt.de>
Wed, 21 Dec 2022 13:18:47 +0000 (14:18 +0100)
committerFlorian Eckert <fe@dev.tdt.de>
Fri, 23 Dec 2022 12:43:32 +0000 (13:43 +0100)
This library needs the kernel config option 'CONFIG_GPIO_CDEV_V1=y' to
be set. If this is not set, the tool 'gpioinfo' produces the error message
'error creating line iterator'. Add the missing kernel config option to
build CDEV with API Version 1 fixes this.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
libs/libgpiod/Makefile

index a5ece1031d43ba527d1259475073ef39dec7d0cb..9859dca27c883a60349495a2af98bf596d67f41b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libgpiod
 PKG_VERSION:=1.6.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/software/libs/libgpiod/
@@ -43,6 +43,9 @@ define Package/libgpiod
   CATEGORY:=Libraries
   URL:=https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git
   TITLE:=Library for interacting with Linux's GPIO character device
+  KCONFIG:= \
+    CONFIG_GPIO_CDEV=y \
+    CONFIG_GPIO_CDEV_V1=y
   DEPENDS:=@GPIO_SUPPORT
 endef