libvorbis: build with LTO on arm 5902/head
authorIan Leonard <antonlacon@gmail.com>
Sat, 7 Apr 2018 19:56:47 +0000 (12:56 -0700)
committerIan Leonard <antonlacon@gmail.com>
Thu, 12 Apr 2018 02:45:06 +0000 (19:45 -0700)
Reduces library size by 0.6%

Signed-off-by: Ian Leonard <antonlacon@gmail.com>
libs/libvorbis/Makefile

index d4e29fce9f1b8c03d033f2ca46f5e84ef986fb82..95c85598be3bc80d5a81f94a3b12612be6e39381 100644 (file)
@@ -41,6 +41,12 @@ software entity may make full use of the format without license
 fee, royalty or patent concerns.
 endef
 
+ifneq ($(findstring arm,$(CONFIG_ARCH)),)
+       TARGET_CFLAGS += -flto
+       TARGET_CXX_FLAGS += -flto
+       TARGET_LDFLAGS += -flto
+endif
+
 CONFIGURE_ARGS+= \
        --disable-oggtest \