opus: Disable ASM for xscale and arm926ej-s 3556/head
authorTed Hess <thess@kitschensync.net>
Wed, 23 Nov 2016 22:22:43 +0000 (17:22 -0500)
committerTed Hess <thess@kitschensync.net>
Wed, 23 Nov 2016 22:22:43 +0000 (17:22 -0500)
Signed-off-by: Ted Hess <thess@kitschensync.net>
libs/opus/Makefile

index 9d74464b94e51663c14970001eb85e9c0136be93..d23e9bbcab6f6e40f59bf0ec664a1bff70a2ad4e 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=opus
 PKG_VERSION:=1.1.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.xiph.org/releases/opus/
@@ -45,6 +45,12 @@ ifeq ($(CONFIG_SOFT_FLOAT),y)
                --enable-fixed-point
 endif
 
+CPU_ASM_BLACKLIST:=xscale arm926ej-s
+
+ifneq ($(findstring $(call qstrip,$(CONFIG_CPU_TYPE)),$(CPU_ASM_BLACKLIST)),)
+       CONFIGURE_ARGS+= --disable-asm
+endif
+
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/opus $(1)/usr/include/