libmicrohttpd: Prevent Recursive Dependency
authorRob White <rob@blue-wave.net>
Sun, 21 Apr 2019 07:18:53 +0000 (08:18 +0100)
committerRob White <rob@blue-wave.net>
Sun, 21 Apr 2019 07:18:53 +0000 (08:18 +0100)
Maintainer: Alexander Couzens lynxis@fe80.eu

Compile Tested: Snapshot SDK

Run Tested: target - ath79, hardware - gl-ar300m16, package - nodogsplash v3.2.1 and nodogsplash v3.3.1, Openwrt Snapshot.

Description: If a package depends on libmicrohttpd but does not specify which variant,
a recursive dependency error occurs caused by the superfluous CONFLICTS line.
With this change, a package will get the named variant, or default to the
no-ssl variant if only libmicrohttpd is specified.

Signed-off-by: Rob White <rob@blue-wave.net>
libs/libmicrohttpd/Makefile

index 3e56be5758f4375e004a34dcb0766939763f672f..93b994b50f9d9478139e1a8909d02356ee51eb76 100644 (file)
@@ -42,7 +42,6 @@ $(call Package/libmicrohttpd/default)
   TITLE+= with SSL support
   VARIANT:=ssl
   DEPENDS:=+libgcrypt +libgnutls +libgpg-error
-  CONFLICTS:=libmicrohttpd-no-ssl
   PROVIDES:=libmicrohttpd
 endef