ath79: update image command for Plasma Cloud PA300
authorSven Wegener <sven.wegener@stealer.net>
Thu, 24 Dec 2020 20:20:53 +0000 (21:20 +0100)
committerDavid Bauer <mail@david-bauer.net>
Fri, 25 Dec 2020 00:57:01 +0000 (01:57 +0100)
Commit 5fc28ef47959 ("ath79: Add support for Plasma Cloud PA300")
added the IMAGE/sysupgrade.bin/squashfs definition, which leaks into
other devices, resulting in sysupgrade.bin images that are actually
tarballs and do not boot when directly written to flash.

We can use the normal sysupgrade.bin command variable for this device.

Signed-off-by: Sven Wegener <sven.wegener@stealer.net>
[fix format, spelling]
Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/ath79/image/generic.mk

index 101c7597b864067eb1233d2cd7ecf06c5e594a2e..ec2b1d2bde4e4cbbf5cc4c27cf02cf4f7bbe66a6 100644 (file)
@@ -1623,7 +1623,7 @@ define Device/plasmacloud_pa300-common
   IMAGES += factory.bin
   KERNEL := kernel-bin | append-dtb | lzma | uImage lzma | pad-to $$(BLOCKSIZE)
   IMAGE/factory.bin := append-rootfs | pad-rootfs | openmesh-image ce_type=PA300
-  IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-rootfs | sysupgrade-tar rootfs=$$$$@ | append-metadata
+  IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | sysupgrade-tar rootfs=$$$$@ | append-metadata
 endef
 
 define Device/plasmacloud_pa300