i2c-tools: Added python3-smbus package 3073/head
authorPaulo Costa <paulo.costa@geofusion.com.br>
Wed, 17 Aug 2016 02:49:06 +0000 (23:49 -0300)
committerPaulo Costa <me@paulo.costa.nom.br>
Wed, 2 Nov 2016 12:46:42 +0000 (10:46 -0200)
This only replicates the existing python-smbus package into Python 3

Signed-off-by: Paulo Costa <me@paulo.costa.nom.br>
utils/i2c-tools/Makefile

index c66c80ea8d40b67cb7f4abb24b83d182be85b9e2..4fb9b50f51b434b2397fccf4621acc3dabfd4604 100644 (file)
@@ -26,6 +26,7 @@ PKG_LICENSE_FILES:=COPYING
 
 include $(INCLUDE_DIR)/package.mk
 $(call include_mk, python-package.mk)
+$(call include_mk, python3-package.mk)
 
 define Package/i2c/Default
   URL:=http://lm-sensors.org/wiki/I2CTools
@@ -48,6 +49,15 @@ define Package/python-smbus
   DEPENDS:=+python-light
 endef
 
+define Package/python3-smbus
+  $(call Package/i2c/Default)
+  SUBMENU:=Python
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=Python bindings for the SMBUS
+  DEPENDS:=+python3-light
+endef
+
 define Package/i2c-tools/description
  This package contains an heterogeneous set of I2C tools for Linux. These tools
  were originally part of the lm-sensors package.
@@ -57,6 +67,10 @@ define Package/python-smbus/description
  This package contain the python bindings for Linux SMBus access through i2c-dev.
 endef
 
+define Package/python3-smbus/description
+ This package contain the python bindings for Linux SMBus access through i2c-dev.
+endef
+
 TARGET_CPPFLAGS += -I$(PKG_BUILD_DIR)/include
 
 ifdef CONFIG_PACKAGE_python-smbus
@@ -68,6 +82,15 @@ ifdef CONFIG_PACKAGE_python-smbus
   endef
 endif
 
+ifdef CONFIG_PACKAGE_python3-smbus
+  define Build/Compile/python3-smbus
+       $(if $(Build/Compile/Py3Mod),,@echo Python3 packaging code not found.; false)
+       $(call Build/Compile/Py3Mod,./py-smbus/, \
+               install --prefix="$(PKG_INSTALL_DIR)/usr", \
+       )
+  endef
+endif
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                LINUX="$(LINUX_DIR)" \
@@ -76,6 +99,7 @@ define Build/Compile
                LDFLAGS="$(TARGET_LDFLAGS)" \
                CFLAGS="$(TARGET_CFLAGS)"
        $(Build/Compile/python-smbus)
+       $(Build/Compile/python3-smbus)
 endef
 
 define Package/i2c-tools/install
@@ -87,9 +111,15 @@ define Package/i2c-tools/install
 endef
 
 define PyPackage/python-smbus/filespec
-+|$(PYTHON_PKG_DIR)/smbus.so
++|$(PYTHON_PKG_DIR)
+endef
+
+define PyPackage/python3-smbus/filespec
++|$(PYTHON3_PKG_DIR)
 endef
 
 $(eval $(call BuildPackage,i2c-tools))
 $(eval $(call PyPackage,python-smbus))
 $(eval $(call BuildPackage,python-smbus))
+$(eval $(call PyPackage,python3-smbus))
+$(eval $(call BuildPackage,python3-smbus))