ath79: add support for ZTE MF282
authorAndreas Böhler <dev@aboehler.at>
Sat, 29 Apr 2023 18:48:47 +0000 (20:48 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 6 May 2023 18:59:46 +0000 (20:59 +0200)
The ZTE MF282 is a LTE router used (exclusively?) by the network operator
"3".

Specifications
==============

SoC: QCA9563 (775MHz)
RAM: 128MiB
Flash: 8MiB SPI-NOR + 128MiB SPI-NAND
LAN: 1x GBit LAN
LTE: ZTE MF270 (Cat4), detected as P685M
WiFi: QCA9880ac + QCA9560bgn

MAC addresses
=============

LAN: from config
WiFi 1: from config
WiFi 2: +1

Installation
============

TFTP installation using UART is preferred. Disassemble the device and
connect serial. Put the initramfs image as openwrt.bin to your TFTP server
and configure a static IP of 192.168.1.100. Load the initramfs image by
typing:

  setenv serverip 192.168.1.100
  setenv ipaddr 192.168.1.1
  tftpboot 0x82000000 openwrt.bin
  bootm 0x82000000

From this intiramfs boot you can take a backup of the currently installed
partitions as no vendor firmware is available for download.

Once booted, transfer the sysupgrade image and run sysupgrade.

LTE Modem
=========

The LTE modem is probably the same as in the MF283+, all instructions
apply.

Configuring the connection using modemmanager works properly, the modem
provides three serial ports and a QMI CDC ethernet interface.

Signed-off-by: Andreas Böhler <dev@aboehler.at>
target/linux/ath79/dts/qca9563_zte_mf282.dts [new file with mode: 0644]
target/linux/ath79/image/nand.mk
target/linux/ath79/nand/base-files/etc/board.d/02_network

diff --git a/target/linux/ath79/dts/qca9563_zte_mf282.dts b/target/linux/ath79/dts/qca9563_zte_mf282.dts
new file mode 100644 (file)
index 0000000..1f3038d
--- /dev/null
@@ -0,0 +1,129 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+// Copyright (c) 2021 Cezary Jackiewicz
+// Copyright (c) 2021, 2022 Lech Perczak
+// Copyright (c) 2022 David Bauer <mail@david-bauer.net>
+// Copyright (c) 2023 Andreas Böhler <dev@aboehler.at>
+
+#include "qca9563_zte_mf28x.dtsi"
+
+/ {
+       model = "ZTE MF282";
+       compatible = "zte,mf282", "qca,qca9563";
+
+       ubi-concat {
+               compatible = "mtd-concat";
+               devices = <&ubiconcat0 &ubiconcat1>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               reg = <0x0 0x7440000>;
+                               label = "ubi";
+                       };
+               };
+       };
+};
+
+&led_debug {
+       label = "blue:debug";
+       color = <LED_COLOR_ID_BLUE>;
+};
+
+&boot_flash {
+       partitions {
+               partition@0 {
+                       label = "u-boot";
+                       reg = <0x0 0x80000>;
+                       read-only;
+               };
+
+               partition@80000 {
+                       label = "u-boot-env";
+                       reg = <0x80000 0x20000>;
+                       read-only;
+               };
+       };
+};
+
+&system_flash {
+       partitions {
+               partition@0 {
+                       label = "fota-flag";
+                       reg = <0x000000 0x140000>;
+                       read-only;
+               };
+
+               partition@140000 {
+                       label = "caldata";
+                       reg = <0x140000 0x140000>;
+                       read-only;
+
+                       compatible = "nvmem-cells";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       cal_caldata_1000: cal@1000 {
+                               reg = <0x1000 0x440>;
+                       };
+
+                       cal_caldata_5000: cal@5000 {
+                               reg = <0x5000 0x844>;
+                       };
+               };
+
+               partition@280000 {
+                       label = "mac";
+                       reg = <0x280000 0x140000>;
+                       read-only;
+
+                       compatible = "nvmem-cells";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       macaddr_mac_0: macaddr@0 {
+                               reg = <0x0 0x6>;
+                       };
+               };
+
+               /* This encompasses stock cfg-param, oops, web partitions,
+                * which can be overwritten safely
+                */
+               ubiconcat0: partition@3c0000 {
+                       label = "ubiconcat0";
+                       reg = <0x3c0000 0xf40000>;
+               };
+
+               /* Kernel MTD size is increased to 8MB from stock 3MB */
+               partition@1300000 {
+                       label = "kernel";
+                       reg = <0x1300000 0x800000>;
+               };
+
+               /* This encompasses stock rootfs, data, fota partitions,
+                * which can be overwritten safely
+                */
+               ubiconcat1: partition@1b00000 {
+                       label = "ubiconcat1";
+                       reg = <0x1b00000 0x6500000>;
+               };
+       };
+};
+
+&eth0 {
+       nvmem-cells = <&macaddr_mac_0>;
+       nvmem-cell-names = "mac-address";
+};
+
+&wifi_ath10k {
+       nvmem-cells = <&macaddr_mac_0>, <&cal_caldata_5000>;
+       nvmem-cell-names = "mac-address", "calibration";
+       mac-address-increment = <1>;
+};
+
+&wmac {
+       nvmem-cells = <&macaddr_mac_0>, <&cal_caldata_1000>;
+       nvmem-cell-names = "mac-address", "calibration";
+};
index 40c57d8b06f74c80011b7cfc655b2bfcdced1b79..10a548501065c57563709661e9c8aa1d9fe01d5d 100644 (file)
@@ -390,6 +390,14 @@ define Device/zte_mf281
 endef
 TARGET_DEVICES += zte_mf281
 
+define Device/zte_mf282
+  $(Device/zte_mf28x_common)
+  DEVICE_MODEL := MF282
+  DEVICE_PACKAGES += ath10k-firmware-qca988x-ct kmod-usb-net-qmi-wwan \
+       kmod-usb-serial-option uqmi
+endef
+TARGET_DEVICES += zte_mf282
+
 define Device/zte_mf286
   $(Device/zte_mf28x_common)
   DEVICE_MODEL := MF286
index 137f3aa11b3549773fbb4fcd739efbc04b76860c..243c5bb7aaae14b080d579500e3db5f4facccfd0 100644 (file)
@@ -66,6 +66,10 @@ ath79_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "0@eth0" "5:lan"
                ;;
+       zte,mf282)
+               ucidef_set_interface_lan "eth0"
+               ucidef_set_interface "wan" device "/dev/cdc-wdm0" protocol "qmi"
+               ;;
        zte,mf286|\
        zte,mf286a|\
        zte,mf286r)