Remove MULTI_CONSOLE_API flag and references to it
authorAmbroise Vincent <ambroise.vincent@arm.com>
Thu, 4 Apr 2019 08:13:28 +0000 (09:13 +0100)
committerAmbroise Vincent <ambroise.vincent@arm.com>
Fri, 28 Jun 2019 09:52:48 +0000 (10:52 +0100)
The new API becomes the default one.

Change-Id: Ic1d602da3dff4f4ebbcc158b885295c902a24fec
Signed-off-by: Ambroise Vincent <ambroise.vincent@arm.com>
44 files changed:
Makefile
drivers/arm/pl011/aarch32/pl011_console.S
drivers/arm/pl011/aarch64/pl011_console.S
drivers/cadence/uart/aarch64/cdns_console.S
drivers/console/aarch64/skeleton_console.S
drivers/console/multi_console.c
drivers/ti/uart/aarch64/16550_console.S
include/drivers/console.h
make_helpers/defaults.mk
plat/allwinner/common/allwinner-common.mk
plat/arm/board/fvp_ve/platform.mk
plat/arm/common/arm_bl31_setup.c
plat/arm/common/arm_common.mk
plat/arm/common/arm_console.c
plat/arm/common/tsp/arm_tsp_setup.c
plat/common/aarch32/crash_console_helpers.S
plat/common/aarch32/plat_sp_min_common.c
plat/common/aarch64/crash_console_helpers.S
plat/common/aarch64/plat_common.c
plat/hisilicon/hikey/platform.mk
plat/hisilicon/hikey960/platform.mk
plat/hisilicon/poplar/platform.mk
plat/imx/imx7/warp7/platform.mk
plat/imx/imx8m/imx8mm/platform.mk
plat/imx/imx8m/imx8mq/platform.mk
plat/imx/imx8qm/platform.mk
plat/imx/imx8qx/platform.mk
plat/intel/soc/stratix10/platform.mk
plat/layerscape/board/ls1043/platform.mk
plat/layerscape/common/aarch64/ls_console.S
plat/layerscape/common/aarch64/ls_helpers.S
plat/marvell/common/marvell_common.mk
plat/meson/gxbb/platform.mk
plat/meson/gxl/platform.mk
plat/qemu/platform.mk
plat/qemu/qemu_console.c
plat/rockchip/rk3328/platform.mk
plat/rockchip/rk3368/platform.mk
plat/rockchip/rk3399/platform.mk
plat/rpi3/platform.mk
plat/socionext/synquacer/platform.mk
plat/st/stm32mp1/platform.mk
plat/ti/k3/common/plat_common.mk
plat/xilinx/versal/platform.mk

index d2e7b5829e8d8475e6881181bf0e0fc958ead5f9..471cf59825e47b2b2c052f8afc212f6bb7f93e0b 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -647,7 +647,6 @@ $(eval $(call assert_boolean,GENERATE_COT))
 $(eval $(call assert_boolean,GICV2_G0_FOR_EL3))
 $(eval $(call assert_boolean,HANDLE_EA_EL3_FIRST))
 $(eval $(call assert_boolean,HW_ASSISTED_COHERENCY))
-$(eval $(call assert_boolean,MULTI_CONSOLE_API))
 $(eval $(call assert_boolean,NS_TIMER_SWITCH))
 $(eval $(call assert_boolean,OVERRIDE_LIBC))
 $(eval $(call assert_boolean,PL011_GENERIC_UART))
@@ -702,7 +701,6 @@ $(eval $(call add_define,GICV2_G0_FOR_EL3))
 $(eval $(call add_define,HANDLE_EA_EL3_FIRST))
 $(eval $(call add_define,HW_ASSISTED_COHERENCY))
 $(eval $(call add_define,LOG_LEVEL))
-$(eval $(call add_define,MULTI_CONSOLE_API))
 $(eval $(call add_define,NS_TIMER_SWITCH))
 $(eval $(call add_define,PL011_GENERIC_UART))
 $(eval $(call add_define,PLAT_${PLAT}))
index b85d2e776c0aeca7544df35445732cabccacdd35..e1e346c2f7bf5c953167ca597cc2df6808088899 100644 (file)
@@ -86,7 +86,6 @@ core_init_fail:
        bx      lr
 endfunc console_pl011_core_init
 
-#if MULTI_CONSOLE_API
        .globl console_pl011_register
 
        /* -------------------------------------------------------
@@ -122,16 +121,6 @@ func console_pl011_register
 register_fail:
        pop     {r4, pc}
 endfunc console_pl011_register
-#else
-       .globl console_core_init
-       .globl console_core_putc
-       .globl console_core_getc
-       .globl console_core_flush
-       .equ console_core_init, console_pl011_core_init
-       .equ console_core_putc, console_pl011_core_putc
-       .equ console_core_getc, console_pl011_core_getc
-       .equ console_core_flush, console_pl011_core_flush
-#endif
 
        /* --------------------------------------------------------
         * int console_core_putc(int c, uintptr_t base_addr)
index c772a9ec3a6b3aac1fb7c2cc4dac47451b9bf256..04de99fbc6f07d8e2bac7b77cf83e00c49fb7ba7 100644 (file)
@@ -75,7 +75,6 @@ core_init_fail:
        ret
 endfunc console_pl011_core_init
 
-#if MULTI_CONSOLE_API
        .globl console_pl011_register
 
        /* -----------------------------------------------
@@ -109,16 +108,6 @@ func console_pl011_register
 register_fail:
        ret     x7
 endfunc console_pl011_register
-#else
-       .globl console_core_init
-       .globl console_core_putc
-       .globl console_core_getc
-       .globl console_core_flush
-       .equ console_core_init,console_pl011_core_init
-       .equ console_core_putc,console_pl011_core_putc
-       .equ console_core_getc,console_pl011_core_getc
-       .equ console_core_flush,console_pl011_core_flush
-#endif
 
        /* --------------------------------------------------------
         * int console_pl011_core_putc(int c, uintptr_t base_addr)
index 8b383799777a548c73a1b5564316a8e13d1a50a5..ecd0c478d2c76692f6826e60c3c9bb4a77ee7224 100644 (file)
@@ -51,7 +51,6 @@ core_init_fail:
        ret
 endfunc console_cdns_core_init
 
-#if MULTI_CONSOLE_API
        .globl console_cdns_register
 
        /* -----------------------------------------------
@@ -85,16 +84,6 @@ func console_cdns_register
 register_fail:
        ret     x7
 endfunc console_cdns_register
-#else
-       .globl console_core_init
-       .globl console_core_putc
-       .globl console_core_getc
-       .globl console_core_flush
-       .equ console_core_init,console_cdns_core_init
-       .equ console_core_putc,console_cdns_core_putc
-       .equ console_core_getc,console_cdns_core_getc
-       .equ console_core_flush,console_cdns_core_flush
-#endif
 
        /* --------------------------------------------------------
         * int console_cdns_core_putc(int c, uintptr_t base_addr)
index 1ba21967822d7e4d8ae287b9354d3be1dc228a0e..c695ddec46ca57b89c7729f2c603b8e794ac935c 100644 (file)
@@ -22,8 +22,6 @@
         * any function may always clobber the intra-procedure-call registers
         * X16 and X17, but may never depend on them retaining their values
         * across any function call.)
-        * Platforms using drivers based on this template need to enable
-        * MULTI_CONSOLE_API := 1 in their platform.mk.
         */
 
        .globl  console_xxx_register
index 1ec81c3c6156f7af830d02d041312393e050f8f0..d9eba7f020e017cff67244b0a694a2edcc1d0d75 100644 (file)
@@ -4,8 +4,6 @@
  * SPDX-License-Identifier: BSD-3-Clause
  */
 
-#if MULTI_CONSOLE_API
-
 #include <assert.h>
 
 #include <drivers/console.h>
@@ -121,5 +119,3 @@ int console_flush(void)
 
        return err;
 }
-
-#endif /* MULTI_CONSOLE_API */
index 55db5031e539e70fe53dd2b3fbbb078dba7d75b6..dab46e8c509935a8087c9b1d081dd68f5ac0c07d 100644 (file)
@@ -83,7 +83,6 @@ init_fail:
        ret
 endfunc console_16550_core_init
 
-#if MULTI_CONSOLE_API
        .globl console_16550_register
 
        /* -----------------------------------------------
@@ -117,16 +116,6 @@ func console_16550_register
 register_fail:
        ret     x7
 endfunc console_16550_register
-#else
-       .globl console_core_init
-       .globl console_core_putc
-       .globl console_core_getc
-       .globl console_core_flush
-       .equ console_core_init,console_16550_core_init
-       .equ console_core_putc,console_16550_core_putc
-       .equ console_core_getc,console_16550_core_getc
-       .equ console_core_flush,console_16550_core_flush
-#endif
 
        /* --------------------------------------------------------
         * int console_16550_core_putc(int c, uintptr_t base_addr)
index 4f26ccef21757a4c53271f9a10026886d0f871ed..f31de95493d802f13c7e5176b1af58a0f30b06b3 100644 (file)
@@ -75,13 +75,6 @@ int console_getc(void);
 /* Flush all consoles registered for the current state. */
 int console_flush(void);
 
-#if !MULTI_CONSOLE_API
-/* REMOVED on AArch64 -- use console_<driver>_register() instead! */
-int console_init(uintptr_t base_addr,
-                unsigned int uart_clk, unsigned int baud_rate);
-void console_uninit(void);
-#endif
-
 #endif /* __ASSEMBLY__ */
 
 #endif /* CONSOLE_H */
index 1d3a7265be33c169b8110b10b99405f3aafb9f1f..f63e46f39f1f3f31832c7e08873dfb869d59147f 100644 (file)
@@ -136,10 +136,6 @@ HW_ASSISTED_COHERENCY              := 0
 # Set the default algorithm for the generation of Trusted Board Boot keys
 KEY_ALG                                := rsa
 
-# Enable use of the console API allowing multiple consoles to be registered
-# at the same time.
-MULTI_CONSOLE_API              := 1
-
 # NS timer register save and restore
 NS_TIMER_SWITCH                        := 0
 
index 585079b751beb3d02252ea08982191b7a6578c3a..6866bd65aa13efea2ffae97548409ae837cbcc6f 100644 (file)
@@ -49,8 +49,6 @@ ERRATA_A53_835769             :=      1
 ERRATA_A53_843419              :=      1
 ERRATA_A53_855873              :=      1
 
-MULTI_CONSOLE_API              :=      1
-
 # The reset vector can be changed for each CPU.
 PROGRAMMABLE_RESET_ADDRESS     :=      1
 
index f9ced2cc3b2e898c5afa7a03d36978717f123e07..f85452dac915a0290c980dae5b9498bb52d7278d 100644 (file)
@@ -106,8 +106,6 @@ endif
 $(eval $(call assert_boolean,ARM_XLAT_TABLES_LIB_V1))
 $(eval $(call add_define,ARM_XLAT_TABLES_LIB_V1))
 
-MULTI_CONSOLE_API              :=      1
-
 ifeq (${ARM_XLAT_TABLES_LIB_V1}, 1)
        # Only use nonlpae version of xlatv1 otherwise use xlat v2
        PLAT_BL_COMMON_SOURCES  +=      lib/xlat_tables/${ARCH}/nonlpae_tables.c
index 8e1a26300e8d12cfc3e5843478be42b7b34aab48..ab90f46a89b907bf77acc2c7a502ffab7177c803 100644 (file)
@@ -240,11 +240,7 @@ void arm_bl31_platform_setup(void)
  ******************************************************************************/
 void arm_bl31_plat_runtime_setup(void)
 {
-#if MULTI_CONSOLE_API
        console_switch_state(CONSOLE_FLAG_RUNTIME);
-#else
-       console_uninit();
-#endif
 
        /* Initialize the runtime console */
        arm_console_runtime_init();
index c3d9e030c19b4d36702d3457dcd3bc5aa8d23a5d..10b6e512269dd5b5e853a8245ad4ecc9871d9043 100644 (file)
@@ -125,9 +125,6 @@ ENABLE_PMF                  :=      1
 # mapping the former as executable and the latter as execute-never.
 SEPARATE_CODE_AND_RODATA       :=      1
 
-# Use the multi console API, which is only available for AArch64 for now
-MULTI_CONSOLE_API              :=      1
-
 # Disable ARM Cryptocell by default
 ARM_CRYPTOCELL_INTEG           :=      0
 $(eval $(call assert_boolean,ARM_CRYPTOCELL_INTEG))
index 580b2ee017d8aa7a6b92526aaaed1554f7e85290..123811d7197c07c883a729975bf76521be31585a 100644 (file)
 /*******************************************************************************
  * Functions that set up the console
  ******************************************************************************/
-#if MULTI_CONSOLE_API
 static console_pl011_t arm_boot_console;
 static console_pl011_t arm_runtime_console;
-#endif
 
 /* Initialize the console to provide early debug support */
 void __init arm_console_boot_init(void)
 {
-#if MULTI_CONSOLE_API
        int rc = console_pl011_register(PLAT_ARM_BOOT_UART_BASE,
                                        PLAT_ARM_BOOT_UART_CLK_IN_HZ,
                                        ARM_CONSOLE_BAUDRATE,
@@ -39,28 +36,17 @@ void __init arm_console_boot_init(void)
        }
 
        console_set_scope(&arm_boot_console.console, CONSOLE_FLAG_BOOT);
-#else
-       (void)console_init(PLAT_ARM_BOOT_UART_BASE,
-                          PLAT_ARM_BOOT_UART_CLK_IN_HZ,
-                          ARM_CONSOLE_BAUDRATE);
-#endif /* MULTI_CONSOLE_API */
 }
 
 void arm_console_boot_end(void)
 {
        (void)console_flush();
-
-#if MULTI_CONSOLE_API
        (void)console_unregister(&arm_boot_console.console);
-#else
-       console_uninit();
-#endif /* MULTI_CONSOLE_API */
 }
 
 /* Initialize the runtime console */
 void arm_console_runtime_init(void)
 {
-#if MULTI_CONSOLE_API
        int rc = console_pl011_register(PLAT_ARM_RUN_UART_BASE,
                                        PLAT_ARM_RUN_UART_CLK_IN_HZ,
                                        ARM_CONSOLE_BAUDRATE,
@@ -69,18 +55,9 @@ void arm_console_runtime_init(void)
                panic();
 
        console_set_scope(&arm_runtime_console.console, CONSOLE_FLAG_RUNTIME);
-#else
-       (void)console_init(PLAT_ARM_RUN_UART_BASE,
-                          PLAT_ARM_RUN_UART_CLK_IN_HZ,
-                          ARM_CONSOLE_BAUDRATE);
-#endif /* MULTI_CONSOLE_API */
 }
 
 void arm_console_runtime_end(void)
 {
        (void)console_flush();
-
-#if !MULTI_CONSOLE_API
-       console_uninit();
-#endif /* !MULTI_CONSOLE_API */
 }
index a3dfa1e1d306bdb48c358178c2ac4dc7d3c08d70..aefdf89c7082365f7a3b11bbfac4660ebac593de 100644 (file)
 /*******************************************************************************
  * Initialize the UART
  ******************************************************************************/
-#if MULTI_CONSOLE_API
 static console_pl011_t arm_tsp_runtime_console;
-#endif
 
 void arm_tsp_early_platform_setup(void)
 {
-#if MULTI_CONSOLE_API
        /*
         * Initialize a different console than already in use to display
         * messages from TSP
@@ -48,10 +45,6 @@ void arm_tsp_early_platform_setup(void)
 
        console_set_scope(&arm_tsp_runtime_console.console,
                          CONSOLE_FLAG_BOOT | CONSOLE_FLAG_RUNTIME);
-#else
-       console_init(PLAT_ARM_TSP_UART_BASE, PLAT_ARM_TSP_UART_CLK_IN_HZ,
-                       ARM_CONSOLE_BAUDRATE);
-#endif /* MULTI_CONSOLE_API */
 }
 
 void tsp_early_platform_setup(void)
index c9ad12cc4fa25ba3944a892df69093eaa22969f0..ea04f56b2fddf0d973badcf62e05ca4f6e6f300d 100644 (file)
@@ -16,8 +16,6 @@
        .globl  plat_crash_console_putc
        .globl  plat_crash_console_flush
 
-#if MULTI_CONSOLE_API
-
        /* -----------------------------------------------------
         * int plat_crash_console_init(void)
         * Use normal console by default. Switch it to crash
@@ -68,25 +66,3 @@ endfunc plat_crash_console_putc
 func plat_crash_console_flush
        b       console_flush
 endfunc plat_crash_console_flush
-
-#else  /* MULTI_CONSOLE_API */
-
-       /* -----------------------------------------------------
-        * In the old API these are all no-op stubs that need to
-        * be overridden by the platform to be useful.
-        * -----------------------------------------------------
-        */
-func plat_crash_console_init
-       mov     r0, #0
-       bx      lr
-endfunc plat_crash_console_init
-
-func plat_crash_console_putc
-       bx      lr
-endfunc plat_crash_console_putc
-
-func plat_crash_console_flush
-       bx      lr
-endfunc plat_crash_console_flush
-
-#endif
index 3bc84b1ad291f9814749b1e270827a34cd463999..949358738032fa1bd978eec944d9431770d4cc6a 100644 (file)
@@ -21,9 +21,5 @@ void sp_min_plat_runtime_setup(void)
         * Finish the use of console driver in SP_MIN so that any runtime logs
         * from SP_MIN will be suppressed.
         */
-#if MULTI_CONSOLE_API
        console_switch_state(CONSOLE_FLAG_RUNTIME);
-#else
-       console_uninit();
-#endif
 }
index 491a99d360e63163896481110c44bc538de41928..2a48baf0a9a7fb702316dea1b093058803f7f3d0 100644 (file)
        .globl  plat_crash_console_putc
        .globl  plat_crash_console_flush
 
-#if !MULTI_CONSOLE_API
-#error "This crash console implementation only works with the MULTI_CONSOLE_API!"
-#endif
-
        /*
         * Spinlock to syncronize access to crash_console_triggered. We cannot
         * acquire spinlocks when the cache is disabled, so in some cases (like
index 1424c7894a0c233fedc07c4d884612857cdbfd86..f8d3129523cf1ed5abf8e3f93d20c8392618c4c2 100644 (file)
 
 void bl31_plat_runtime_setup(void)
 {
-#if MULTI_CONSOLE_API
        console_switch_state(CONSOLE_FLAG_RUNTIME);
-#else
-       console_uninit();
-#endif
 }
 
 /*
index 99887eeef85b136fe28ca94b89aee8ce77cba6da..7fd897cdab134be222c6e9d54de27d0e6b7e6be6 100644 (file)
@@ -20,7 +20,6 @@ endif
 
 CONSOLE_BASE                   :=      PL011_UART3_BASE
 CRASH_CONSOLE_BASE             :=      PL011_UART3_BASE
-MULTI_CONSOLE_API              :=      1
 PLAT_PARTITION_MAX_ENTRIES     :=      12
 PLAT_PL061_MAX_GPIOS           :=      160
 COLD_BOOT_SINGLE_CPU           :=      1
index 8ff303fdc86211042c5cc16e2b17004271baddff..4f2c3c699fef0afee85b8418d13e15490ab26d31 100644 (file)
@@ -17,7 +17,6 @@ else
   $(error "Currently unsupported HIKEY960_TSP_RAM_LOCATION value")
 endif
 
-MULTI_CONSOLE_API              :=      1
 CRASH_CONSOLE_BASE             :=      PL011_UART6_BASE
 COLD_BOOT_SINGLE_CPU           :=      1
 PLAT_PL061_MAX_GPIOS           :=      176
index a1535a4d4b851e241bd82ff3ca9bf21fda16e7ba..b5d986760c80f0cc2bae67b246d3db051bfa228f 100644 (file)
@@ -46,7 +46,6 @@ ERRATA_A53_855873             := 1
 ERRATA_A53_835769              := 1
 ERRATA_A53_843419              := 1
 ENABLE_SVE_FOR_NS              := 0
-MULTI_CONSOLE_API              := 1
 WORKAROUND_CVE_2017_5715       := 0
 
 PLAT_PL061_MAX_GPIOS           := 104
index 6cd7566e9e233aae7fa13fea7827507899aa8e48..d266768269d35c2ad0c7668269e9764fc8a39639 100644 (file)
@@ -119,9 +119,6 @@ SEPARATE_CODE_AND_RODATA    := 1
 # Use Coherent memory
 USE_COHERENT_MEM               := 1
 
-# Use multi console API
-MULTI_CONSOLE_API               := 1
-
 # PLAT_WARP7_UART
 PLAT_WARP7_UART                        :=1
 $(eval $(call add_define,PLAT_WARP7_UART))
index bd1c058396c181c7aad0daabe362241c9408f307..a3d249a65a274bef16bc6807861d0dd220736c1f 100644 (file)
@@ -39,7 +39,6 @@ BL31_SOURCES          +=      plat/imx/common/imx8_helpers.S                  \
 USE_COHERENT_MEM       :=      1
 RESET_TO_BL31          :=      1
 A53_DISABLE_NON_TEMPORAL_HINT := 0
-MULTI_CONSOLE_API      :=      1
 
 ERRATA_A53_835769      :=      1
 ERRATA_A53_843419      :=      1
index c6bec6f3c4190f686a54dbab4ac66cb4226168cb..d6879bf74ba5d5d1d7f3a47ef0a4db09c2d11857 100644 (file)
@@ -39,7 +39,6 @@ BL31_SOURCES          +=      plat/imx/common/imx8_helpers.S                  \
 USE_COHERENT_MEM       :=      1
 RESET_TO_BL31          :=      1
 A53_DISABLE_NON_TEMPORAL_HINT := 0
-MULTI_CONSOLE_API      :=      1
 
 ERRATA_A53_835769      :=      1
 ERRATA_A53_843419      :=      1
index ed6108d8db2d9439e0aa5a725af8b0a857067335..3a772e51a807573a6e0865dd14baab705ba8b550 100644 (file)
@@ -36,7 +36,6 @@ include plat/imx/common/sci/sci_api.mk
 USE_COHERENT_MEM       :=      1
 RESET_TO_BL31          :=      1
 A53_DISABLE_NON_TEMPORAL_HINT := 0
-MULTI_CONSOLE_API      :=      1
 ERRATA_A72_859971      :=      1
 
 ERRATA_A53_835769      :=      1
index eeb1f34ed4955b23708ede07a3c87506aa9f7738..d5629d124507a2add21f3f3e8b866efdcfdde993 100644 (file)
@@ -33,4 +33,3 @@ include plat/imx/common/sci/sci_api.mk
 
 USE_COHERENT_MEM       :=      1
 RESET_TO_BL31          :=      1
-MULTI_CONSOLE_API      :=      1
index fdd6e45b06c450e9903c7c5ced39a539ba809db5..fd91e58ad43a872abe0cd6087bc16dd15045a1c3 100644 (file)
@@ -67,5 +67,4 @@ BL31_SOURCES  +=      drivers/arm/cci/cci.c                           \
 
 PROGRAMMABLE_RESET_ADDRESS     := 0
 BL2_AT_EL3                     := 1
-MULTI_CONSOLE_API              := 1
 USE_COHERENT_MEM               := 1
index 2e0e59bd5c34bdc5cf06c8f9799603231b14085d..d716c61e246617fa640a4a6241545f3945fe4bce 100644 (file)
@@ -56,9 +56,6 @@ BL31_SOURCES                  +=      plat/layerscape/board/ls1043/ls1043_bl31_setup.c                \
                                        ${LS1043_INTERCONNECT_SOURCES}                  \
                                        ${LS1043_SECURITY_SOURCES}
 
-# Disable the PSCI platform compatibility layer
-MULTI_CONSOLE_API              :=      1
-
 # Enable workarounds for selected Cortex-A53 erratas.
 ERRATA_A53_855873              :=      1
 
index a3c270dcd4e89beaa3dca5bf856da910dc712df6..f8948b4abc95f311e1e2772a13565d44824804c8 100644 (file)
@@ -78,7 +78,6 @@ init_fail:
        ret
 endfunc console_ls_16550_core_init
 
-#if MULTI_CONSOLE_API
        .globl console_ls_16550_register
 
        /* -----------------------------------------------
@@ -111,16 +110,6 @@ func console_ls_16550_register
 register_fail:
        ret     x7
 endfunc console_ls_16550_register
-#else
-       .globl console_core_init
-       .globl console_core_putc
-       .globl console_core_getc
-       .globl console_core_flush
-       .equ console_core_init,console_ls_16550_core_init
-       .equ console_core_putc,console_ls_16550_core_putc
-       .equ console_core_getc,console_ls_16550_core_getc
-       .equ console_core_flush,console_ls_16550_core_flush
-#endif
 
        /* --------------------------------------------------------
         * int console_ls_16550_core_putc(int c, uintptr_t base_addr)
index bbddd0b5108533b54eb3510ca6494b409da62804..5aa5497777e2c71fc8396470da1e371ff01506c1 100644 (file)
@@ -49,7 +49,6 @@ endfunc plat_ls_calc_core_pos
         * ---------------------------------------------
         */
 
-#if MULTI_CONSOLE_API
        /* -----------------------------------------------------
         * int plat_crash_console_init(void)
         * Use normal console by default. Switch it to crash
@@ -101,45 +100,6 @@ func plat_crash_console_flush
        b       console_flush
 endfunc plat_crash_console_flush
 
-#else  /* MULTI_CONSOLE_API */
-
-       /* -----------------------------------------------------
-        * In the old API these are all no-op stubs that need to
-        * be overridden by the platform to be useful.
-        * -----------------------------------------------------
-        */
-func plat_crash_console_init
-       mov_imm x0, PLAT_LS1043_UART_BASE
-       mov_imm x1, PLAT_LS1043_UART_CLOCK
-       mov_imm x2, PLAT_LS1043_UART_BAUDRATE
-       b       console_core_init
-endfunc plat_crash_console_init
-
-       /* ---------------------------------------------
-        * int plat_crash_console_putc(int c)
-        * Function to print a character on the crash
-        * console without a C Runtime.
-        * Clobber list : x1, x2
-        * ---------------------------------------------
-        */
-func plat_crash_console_putc
-       mov_imm x1, PLAT_LS1043_UART_BASE
-       b       console_core_putc
-endfunc plat_crash_console_putc
-
-       /* ---------------------------------------------
-        * int plat_crash_console_flush()
-        * Function to force a write of all buffered
-        * data that hasn't been output.
-        * Out : return -1 on error else return 0.
-        * Clobber list : r0 - r1
-        * ---------------------------------------------
-        */
-func plat_crash_console_flush
-       mov_imm x1, PLAT_LS1043_UART_BASE
-       b       console_core_flush
-endfunc plat_crash_console_flush
-#endif
        /* ---------------------------------------------------------------------
         * We don't need to carry out any memory initialization on LS
         * platforms. The Secure SRAM is accessible straight away.
index a1282619582faafae4ce398da2c9d1d75746c8fc..5c8e804f2046b88541f88ada913d231b7104b245 100644 (file)
@@ -11,8 +11,6 @@ include $(MARVELL_PLAT_BASE)/marvell.mk
 
 VERSION_STRING                 +=(Marvell-${SUBVERSION})
 
-MULTI_CONSOLE_API              := 1
-
 SEPARATE_CODE_AND_RODATA       := 1
 
 # flag to switch from PLL to ARO
index 9669bf9590e58391690539c6a5123475385a1d9c..9e65040b976016afbf5b4c4a8f5afba39bbcc9d3 100644 (file)
@@ -57,16 +57,9 @@ SEPARATE_CODE_AND_RODATA     := 1
 # Use Coherent memory
 USE_COHERENT_MEM               := 1
 
-# Use multi console API
-MULTI_CONSOLE_API              := 1
-
 # Verify build config
 # -------------------
 
-ifneq (${MULTI_CONSOLE_API}, 1)
-  $(error Error: gxbb needs MULTI_CONSOLE_API=1)
-endif
-
 ifneq (${RESET_TO_BL31}, 0)
   $(error Error: gxbb needs RESET_TO_BL31=0)
 endif
index ea4aead72e6fc9ea590977da9badc3f5ad04616c..a788e96393d0fca046d721762b347acb624230de 100644 (file)
@@ -62,16 +62,9 @@ SEPARATE_CODE_AND_RODATA     := 1
 # Use Coherent memory
 USE_COHERENT_MEM               := 1
 
-# Use multi console API
-MULTI_CONSOLE_API              := 1
-
 # Verify build config
 # -------------------
 
-ifneq (${MULTI_CONSOLE_API}, 1)
-  $(error Error: gxl needs MULTI_CONSOLE_API=1)
-endif
-
 ifneq (${RESET_TO_BL31}, 0)
   $(error Error: gxl needs RESET_TO_BL31=0)
 endif
index f086ddc6ca5e98eb73e3e51b86a7a9fb0e908f46..85d83eaa78d9bb59a246d30f24b4d6ae535f3d09 100644 (file)
@@ -151,12 +151,6 @@ ifneq ($(ENABLE_STACK_PROTECTOR), 0)
        PLAT_BL_COMMON_SOURCES += plat/qemu/qemu_stack_protector.c
 endif
 
-# Use MULTI_CONSOLE_API by default only on AArch64
-# as it is not yet supported on AArch32
-ifeq ($(ARCH),aarch64)
-MULTI_CONSOLE_API      := 1
-endif
-
 BL32_RAM_LOCATION      :=      tdram
 ifeq (${BL32_RAM_LOCATION}, tsram)
   BL32_RAM_LOCATION_ID = SEC_SRAM_ID
index 759f997dcbb71f253e4eea8ce69e8cedeeacdf04..fec182892166b824002c6079a1f183d48a1a3def 100644 (file)
@@ -9,23 +9,15 @@
 #include <drivers/console.h>
 #include <drivers/arm/pl011.h>
 
-#if MULTI_CONSOLE_API
 static console_pl011_t console;
-#endif /* MULTI_CONSOLE_API */
 
 void qemu_console_init(void)
 {
-#if MULTI_CONSOLE_API
        (void)console_pl011_register(PLAT_QEMU_BOOT_UART_BASE,
                               PLAT_QEMU_BOOT_UART_CLK_IN_HZ,
                               PLAT_QEMU_CONSOLE_BAUDRATE, &console);
 
        console_set_scope(&console.console, CONSOLE_FLAG_BOOT |
                          CONSOLE_FLAG_RUNTIME);
-#else
-       console_init(PLAT_QEMU_BOOT_UART_BASE,
-                    PLAT_QEMU_BOOT_UART_CLK_IN_HZ,
-                    PLAT_QEMU_CONSOLE_BAUDRATE);
-#endif /* MULTI_CONSOLE_API */
 }
 
index 3e7033049e4ad44f823045e49e5dbef3bebbf3fb..fa207aa5044b0be2e175bf3c2efbd9dcf8914c4a 100644 (file)
@@ -51,8 +51,6 @@ BL31_SOURCES          +=      ${RK_GIC_SOURCES}                               \
                                ${RK_PLAT_SOC}/drivers/pmu/pmu.c                \
                                ${RK_PLAT_SOC}/drivers/soc/soc.c
 
-MULTI_CONSOLE_API      :=      1
-
 include lib/coreboot/coreboot.mk
 include lib/libfdt/libfdt.mk
 
index 51368dea92399934fd2c1e4ce86521d13bd639c2..f8878f1db178dae058ffa718bb7dcd77aebc51d1 100644 (file)
@@ -50,8 +50,6 @@ BL31_SOURCES          +=      ${RK_GIC_SOURCES}                               \
                                ${RK_PLAT_SOC}/drivers/soc/soc.c                \
                                ${RK_PLAT_SOC}/drivers/ddr/ddr_rk3368.c         \
 
-MULTI_CONSOLE_API      :=      1
-
 include lib/coreboot/coreboot.mk
 include lib/libfdt/libfdt.mk
 
index f917f61ba0691190bc9862fe08d6328a873d6fbf..1d81d7e9fa03adb908a6ddf8223187a432d388ce 100644 (file)
@@ -67,8 +67,6 @@ BL31_SOURCES  +=      ${RK_GIC_SOURCES}                               \
                        ${RK_PLAT_SOC}/drivers/dram/dram_spec_timing.c  \
                        ${RK_PLAT_SOC}/drivers/dram/suspend.c
 
-MULTI_CONSOLE_API      :=      1
-
 include lib/coreboot/coreboot.mk
 include lib/libfdt/libfdt.mk
 
index ca638d59175ea54c918adc12164c81387b574cb0..f238cd61dab64a3d10eda9a1e2c1af89785117c4 100644 (file)
@@ -102,9 +102,6 @@ SEPARATE_CODE_AND_RODATA    := 1
 # Use Coherent memory
 USE_COHERENT_MEM               := 1
 
-# Use multi console API
-MULTI_CONSOLE_API              := 1
-
 # Platform build flags
 # --------------------
 
@@ -152,10 +149,6 @@ ifneq (${RPI3_DIRECT_LINUX_BOOT}, 0)
   endif
 endif
 
-ifneq (${MULTI_CONSOLE_API}, 1)
-  $(error Error: rpi3 needs MULTI_CONSOLE_API=1)
-endif
-
 ifneq (${RESET_TO_BL31}, 0)
   $(error Error: rpi3 needs RESET_TO_BL31=0)
 endif
index f5e72cb6441309bbbe168d6ad16ab78f1115af75..fe1448ff109e2a5a5f36461d04e64ab6d7bba66e 100644 (file)
@@ -5,7 +5,6 @@
 #
 
 override RESET_TO_BL31                 := 1
-override MULTI_CONSOLE_API             := 1
 override PROGRAMMABLE_RESET_ADDRESS    := 1
 override USE_COHERENT_MEM              := 1
 override SEPARATE_CODE_AND_RODATA      := 1
index f6bf9f3f4e83063aa2647cf1bdc1efba3f359b40..0ea7bbb8e6dba9a960bde3c81ce94f513c141454 100644 (file)
@@ -8,7 +8,6 @@ ARM_CORTEX_A7           :=      yes
 ARM_WITH_NEON          :=      yes
 BL2_AT_EL3             :=      1
 USE_COHERENT_MEM       :=      0
-MULTI_CONSOLE_API      :=      1
 
 STM32_TF_VERSION       ?=      0
 
index 83e9c62a01db086ec74686222c2ad9d33d8d3c3f..f154a960099059234b7f52e5a8fc9905a6b0c37e 100644 (file)
@@ -28,7 +28,6 @@ ERRATA_A72_859971     :=      1
 # Split out RO data into a non-executable section
 SEPARATE_CODE_AND_RODATA :=    1
 
-MULTI_CONSOLE_API      :=      1
 TI_16550_MDR_QUIRK     :=      1
 $(eval $(call add_define,TI_16550_MDR_QUIRK))
 
index 1532d9285d8e25ef5b064d759d86b3bbf3f9806f..1c56364c85abf1297c32966c27efcf00696f4dff 100644 (file)
@@ -8,7 +8,6 @@ A53_DISABLE_NON_TEMPORAL_HINT := 0
 SEPARATE_CODE_AND_RODATA := 1
 override RESET_TO_BL31 := 1
 PL011_GENERIC_UART := 1
-MULTI_CONSOLE_API := 1
 
 ifdef VERSAL_ATF_MEM_BASE
     $(eval $(call add_define,VERSAL_ATF_MEM_BASE))