mdio-tools: add kmod-mdio-netlink as dependencies
authorChukun Pan <amadeus@jmu.edu.cn>
Sat, 2 Apr 2022 14:28:26 +0000 (22:28 +0800)
committerNick Hainke <vincent@systemli.org>
Sun, 24 Apr 2022 09:02:43 +0000 (11:02 +0200)
Otherwise it will fail as follows:
  failed to find a module named mdio-netlink
  ERROR: mdio-netlink module not detected, and could not be loaded.

Run-tested on: ramips/mt7621

Signed-off-by: Chukun Pan <amadeus@jmu.edu.cn>
net/mdio-tools/Makefile

index e44776ab5fdc067b924906ee5cb79d9153b1bd9e..c110bfdcfdb29693d80636d12de3de2306cf52c2 100644 (file)
@@ -1,7 +1,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mdio-tools
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_URL:=https://github.com/wkz/mdio-tools
 PKG_SOURCE_PROTO:=git
@@ -22,7 +22,7 @@ define Package/mdio-tools
   CATEGORY:=Utilities
   TITLE:=mdio-tools Linux MDIO register access
   URL:=https://github.com/wkz/mdio-tools.git
-  DEPENDS:=+libmnl
+  DEPENDS:=+kmod-mdio-netlink +libmnl
 endef
 
 define Package/mdio-tools/description