knot-resolver: update to 5.5.3 19422/head
authorMichal Vasilek <michal.vasilek@nic.cz>
Thu, 22 Sep 2022 17:47:41 +0000 (19:47 +0200)
committerMichal Vasilek <michal.vasilek@nic.cz>
Thu, 22 Sep 2022 18:10:13 +0000 (20:10 +0200)
* fixes CVE-2022-40188

Signed-off-by: Michal Vasilek <michal.vasilek@nic.cz>
net/knot-resolver/Makefile
net/knot-resolver/patches/010-fix-lmdb.patch
net/knot-resolver/patches/030-fix-policy-hack.patch

index cb3773762d683ab18098a17c37e466ab8108100f..31cb3654ccbd4ed0c748a6fb5419e987ff81550b 100644 (file)
@@ -10,12 +10,12 @@ PKG_RELRO_FULL:=0
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=knot-resolver
-PKG_VERSION:=5.5.1
+PKG_VERSION:=5.5.3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://secure.nic.cz/files/knot-resolver
-PKG_HASH:=9bad1edfd6631446da2d2331bd869887d7fe502f6eeaf62b2e43e2c113f02b6d
+PKG_HASH:=a38f57c68b7d237d662784d8406e6098aad66a148f44dcf498d1e9664c5fed2d
 
 PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec1@gmail.com>
 PKG_LICENSE:=GPL-3.0-later
index 890c4a027590cadc2b34278a45e5a8ed7939f9a8..4168226461a131a781ca2a6568f36f0a644b726f 100644 (file)
@@ -1,5 +1,5 @@
 This is just workaround. It should be removed after proper fixing in upstream.
-Patch fixes problem with lmdb pkg config. It also adds workaround for get_option
+Patch fixes problem with lmdb pkg confing. It also adds workaround for get_option
 which is now not propagated in OpenWrt meson host package.
 --- a/meson.build
 +++ b/meson.build
index 70c6f81b064e68ba29cff47249f4dea0fb5e51eb..cbc2ce370611465cb401afdd54ad1a8f1d7d4621 100644 (file)
@@ -2,7 +2,7 @@ This patch fixes the problem with forwarding in knot-resolver v4.3.0.
 It reintroduces a fix which enables  policy related hack (knot/knot-resolver#205 (comment 94566) )
 --- a/modules/policy/policy.lua
 +++ b/modules/policy/policy.lua
-@@ -1098,7 +1098,7 @@ policy.layer = {
+@@ -1093,7 +1093,7 @@ policy.layer = {
                if bit.band(state, bit.bor(kres.FAIL, kres.DONE)) ~= 0 then return state end
                local qry = req:initial() -- same as :current() but more descriptive
                return policy.evaluate(policy.rules, req, qry, state)