ddns-scripts: enable IPv6 for easydns.com 20529/head
authorJames Buren <braewoods+mgh@braewoods.net>
Mon, 20 Feb 2023 11:51:46 +0000 (05:51 -0600)
committerJames Buren <braewoods+mgh@braewoods.net>
Thu, 23 Feb 2023 01:24:21 +0000 (19:24 -0600)
easydns.com has supported IPv6 for awhile now using
the same update URL as IPv4. This duplicates the IPv4
entry for IPv6 to enable support for it.

Signed-off-by: James Buren <braewoods+mgh@braewoods.net>
net/ddns-scripts/Makefile
net/ddns-scripts/files/usr/share/ddns/default/easydns.com.json

index 5729305dcba2f2ca21cccaf6b977dbda082cdc99..1c5d98814ff71cf5e741c62a5a233d3a296d58e7 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ddns-scripts
 PKG_VERSION:=2.8.2
-PKG_RELEASE:=34
+PKG_RELEASE:=35
 
 PKG_LICENSE:=GPL-2.0
 
index 6f6855d15e06b3aa629c5baabf4e4bb2bca14531..0642c38dd0aa60356d8547c2b6c7b76002f27264 100644 (file)
@@ -3,5 +3,9 @@
        "ipv4": {
                "url": "http://[USERNAME]:[PASSWORD]@api.cp.easydns.com/dyn/generic.php?hostname=[DOMAIN]&myip=[IP]",
                "answer": "OK|NOERROR"
+       },
+       "ipv6": {
+               "url": "http://[USERNAME]:[PASSWORD]@api.cp.easydns.com/dyn/generic.php?hostname=[DOMAIN]&myip=[IP]",
+               "answer": "OK|NOERROR"
        }
 }