strongswan: local_gateway unused in swanctl.init 20857/head
authorPhilip Prindeville <philipp@redfish-solutions.com>
Fri, 21 Apr 2023 18:02:28 +0000 (12:02 -0600)
committerPhilip Prindeville <philipp@redfish-solutions.com>
Sun, 23 Apr 2023 00:20:38 +0000 (18:20 -0600)
Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
net/strongswan/Makefile
net/strongswan/files/swanctl.init

index 7f0e0c9609a128b5a5e1f93d8a3d3d8fd495c6a3..7b5275ba7adad14dd2d163b0bbe5aed795a742c2 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=strongswan
 PKG_VERSION:=5.9.10
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://download.strongswan.org/ https://download2.strongswan.org/
index f32ca21c4a6e2deb79d5f76a9e17e85f85705b96..e05c7228d95c56df64a8b8ea3050679ba95fc602 100644 (file)
@@ -418,7 +418,6 @@ config_connection() {
 
        local enabled
        local gateway
-       local local_gateway
        local local_sourceip
        local local_ip
        local remote_gateway
@@ -478,10 +477,6 @@ config_connection() {
 
        [ "$gateway" = "any" ] && remote_gateway="%any" || remote_gateway="$gateway"
 
-       local ipdest
-       [ "$remote_gateway" = "%any" ] && ipdest="1.1.1.1" || ipdest="$remote_gateway"
-       local_gateway=`ip -o route get $ipdest | awk '/ src / { gsub(/^.* src /,""); gsub(/ .*$/, ""); print $0}'`
-
        if [ -n "$local_key" ]; then
                [ "$(dirname "$local_key")" != "." ] && \
                   fatal "local_key $local_key can't be pathname"