openvswitch: fix libunbound dependency check
authorMatthew Hagan <mathagan@fb.com>
Wed, 15 Dec 2021 15:42:09 +0000 (15:42 +0000)
committerYousong Zhou <yszhou4tech@gmail.com>
Thu, 16 Dec 2021 05:25:37 +0000 (13:25 +0800)
The ifeq check for CONFIG_OPENVSWITCH_WITH_LIBUNBOUND does not evaluate
correctly within the menuconfig, resulting in libunbound not being
selected, resulting in a failing libunbound.so.8 dependency.

Instead add this condition:dependency in the manner defined in the
OpenWrt developer guide.

Signed-off-by: Matthew Hagan <mathagan@fb.com>
net/openvswitch/Makefile

index f9c212da15ae1a38bf4e02e6ec1b6db585885114..abd202edaa44816e489204d0ec6487f9d4be93a3 100644 (file)
@@ -153,10 +153,9 @@ $(eval $(call OvsKmodPackageTemplate,openvswitch-lisp-intree))
 #
 ovs_libopenvswitch_title:=Open vSwitch (libopenvswitch.so)
 ovs_libopenvswitch_hidden:=1
-ovs_libopenvswitch_depends:= +libatomic +libopenssl +!(arc||arceb):libunwind
-ifeq ($(CONFIG_OPENVSWITCH_WITH_LIBUNBOUND),y)
-ovs_libopenvswitch_depends+=+libunbound
-endif
+ovs_libopenvswitch_depends:= \
+       +libatomic +libopenssl +OPENVSWITCH_WITH_LIBUNBOUND:libunbound \
+       +!(arc||arceb):libunwind
 ovs_libopenvswitch_files:=usr/lib/libopenvswitch*.so*
 $(eval $(call OvsPackageTemplate,libopenvswitch))