qemu: add zstd option
authorVladimir Ermakov <vooon341@gmail.com>
Thu, 20 Apr 2023 12:26:50 +0000 (14:26 +0200)
committerYousong Zhou <yszhou4tech@gmail.com>
Sun, 23 Apr 2023 10:35:39 +0000 (18:35 +0800)
Signed-off-by: Vladimir Ermakov <vooon341@gmail.com>
utils/qemu/Makefile

index 167df82dc7f99e1ee14e6cdcb1e2c8e6d90aa38a..509b03f38ab55f41d68fd0cabb6d705e15cfba6a 100644 (file)
@@ -91,7 +91,7 @@ define Package/qemu-img
  SUBMENU:=Virtualization
  TITLE:=QEMU Image utility
  URL:=http://www.qemu.org
- DEPENDS:=+glib2 $(QEMU_DEPS_IN_HOST)
+ DEPENDS:=+glib2 +QEMU_ZSTD:libzstd $(QEMU_DEPS_IN_HOST)
 endef
 
 define Package/qemu-img/install
@@ -106,7 +106,7 @@ define Package/qemu-nbd
  SUBMENU:=Virtualization
  TITLE:=QEMU Network Block Device Utility
  URL:=http://www.qemu.org
- DEPENDS:=+glib2 $(QEMU_DEPS_IN_HOST) +kmod-nbd
+ DEPENDS:=+glib2 +QEMU_ZSTD:libzstd $(QEMU_DEPS_IN_HOST) +kmod-nbd
 endef
 
 define Package/qemu-nbd/install
@@ -198,6 +198,7 @@ define qemu-target
        +QEMU_UI_SPICE:libspice-server \
        +QEMU_DEV_USB:libusb-1.0 \
        +QEMU_SECCOMP:libseccomp \
+       +QEMU_ZSTD:libzstd \
        $(if $(filter %-softmmu,$(1)),+libncurses +libfdt +libslirp +libudev +pixman +qemu-firmware-efi $(ICONV_DEPENDS))
   endef
 
@@ -265,6 +266,10 @@ config QEMU_SECCOMP
          Build QEMU with support for seccomp filters.
          Select libseccomp which also pulls-in the needed kernel features.
 
+config QEMU_ZSTD
+       bool "QEMU ZSTD compression support"
+       default n
+
 endif
 endef
 
@@ -275,6 +280,7 @@ PKG_CONFIG_DEPENDS += \
        CONFIG_QEMU_UI_SPICE \
        CONFIG_QEMU_DEV_USB \
        CONFIG_QEMU_SECCOMP \
+       CONFIG_QEMU_ZSTD \
 
 
 # QEMU configure script does not recognize these options
@@ -424,7 +430,7 @@ CONFIGURE_ARGS +=                   \
        --disable-werror                \
        --disable-xen-pci-passthrough   \
        --disable-xkbcommon             \
-       --disable-zstd                  \
+       --$(if $(CONFIG_QEMU_ZSTD),enable,disable)-zstd                 \
        --disable-selinux               \
        --disable-oss                   \
        --disable-alsa                  \