projects
/
openwrt
/
staging
/
wigyori.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
9374204
)
bundle ehci-orion with kmod-usb2
author
Imre Kaloz
<kaloz@openwrt.org>
Tue, 17 Jun 2014 15:02:28 +0000
(15:02 +0000)
committer
Imre Kaloz
<kaloz@openwrt.org>
Tue, 17 Jun 2014 15:02:28 +0000
(15:02 +0000)
SVN-Revision: 41230
package/kernel/linux/modules/usb.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/usb.mk
b/package/kernel/linux/modules/usb.mk
index 47e337284a330fba8f6d9c193b95a057a29b1a22..9aa3e8c7028a6e1ec4cfe451b6ff699014172ffd 100644
(file)
--- a/
package/kernel/linux/modules/usb.mk
+++ b/
package/kernel/linux/modules/usb.mk
@@
-394,6
+394,9
@@
ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.8.0)),1)
FILES:= \
$(LINUX_DIR)/drivers/usb/host/ehci-hcd.ko \
$(LINUX_DIR)/drivers/usb/host/ehci-platform.ko
+ ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/host/ehci-orion.ko),)
+ FILES+=$(LINUX_DIR)/drivers/usb/host/ehci-orion.ko
+ endif
AUTOLOAD:=$(call AutoLoad,40,ehci-hcd ehci-platform,1)
else
FILES:=$(LINUX_DIR)/drivers/usb/host/ehci-hcd.ko