mysql: only use g++-uc wrapper with uClibc++
authorNicolas Thill <nico@openwrt.org>
Fri, 3 Apr 2015 05:44:23 +0000 (07:44 +0200)
committerNicolas Thill <nico@openwrt.org>
Fri, 3 Apr 2015 05:44:23 +0000 (07:44 +0200)
Signed-off-by: Nicolas Thill <nico@openwrt.org>
utils/mysql/Makefile

index 16312b3f1d46120908aec343105a6ac043ab4fc8..f0553a9d73eea94ed1d26dfb752bd35b54ebb22c 100644 (file)
@@ -58,7 +58,9 @@ define Package/libmysqlclient-r
   DEPENDS+= +libpthread
 endef
 
-TARGET_CXX=g++-uc
+ifneq ($(CONFIG_USE_UCLIBCXX),)
+  TARGET_CXX=g++-uc
+endif
 
 TARGET_CFLAGS += $(FPIC)