qemu: update to 8.0.0
authorVladimir Ermakov <vooon341@gmail.com>
Thu, 20 Apr 2023 10:23:19 +0000 (12:23 +0200)
committerYousong Zhou <yszhou4tech@gmail.com>
Sun, 23 Apr 2023 10:35:39 +0000 (18:35 +0800)
- Update version to 8.0.0
- Refresh patches
- Update configure opttions to disable libdw

Signed-off-by: Vladimir Ermakov <vooon341@gmail.com>
utils/qemu/Makefile
utils/qemu/patches/0001-configure-allow-disable-fortify_source.patch
utils/qemu/patches/0007-qga-invoke-separate-applets-for-guest-shutdown-modes.patch
utils/qemu/patches/0010-no-tests.patch

index 8e5819c40d67dbd1bd4bcda9e9b5ff512900689e..167df82dc7f99e1ee14e6cdcb1e2c8e6d90aa38a 100644 (file)
@@ -9,10 +9,10 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=qemu
-PKG_VERSION:=7.2.0
+PKG_VERSION:=8.0.0
 PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_HASH:=5b49ce2687744dad494ae90a898c52204a3406e84d072482a1e1be854eeb2157
+PKG_HASH:=bb60f0341531181d6cc3969dd19a013d0427a87f918193970d9adb91131e56d0
 PKG_SOURCE_URL:=http://download.qemu.org/
 PKG_LICENSE:=GPL-2.0-only
 PKG_LICENSE_FILES:=LICENSE tcg/LICENSE
@@ -430,6 +430,7 @@ CONFIGURE_ARGS +=                   \
        --disable-alsa                  \
        --disable-pa                    \
        --disable-vduse-blk-export      \
+       --disable-libdw                 \
 
 CONFIGURE_ARGS += --target-list='$(foreach target,$(qemu-target-list),$(if $(CONFIG_PACKAGE_qemu-$(target)),$(target)))'
 CONFIGURE_ARGS += $(if $(CONFIG_PACKAGE_qemu-ga),--enable-guest-agent)
index e4404a987f1ce9d6021a0a35b4035fe5b14e8d42..42d41305e66187e94be7fc109366af149711fcac 100644 (file)
@@ -11,9 +11,9 @@ OpenWrt base build system decide flavor of fortify_source to use
 
 --- a/configure
 +++ b/configure
-@@ -896,6 +896,8 @@ for opt do
+@@ -895,6 +895,8 @@ for opt do
    ;;
-   --enable-jemalloc) meson_option_parse --enable-malloc=jemalloc jemalloc
+   --disable-vfio-user-server) vfio_user_server="disabled"
    ;;
 +  --disable-fortify-source) fortify_source="no"
 +  ;;
index 2c7e39e12a62b9e29f5a2857040c6fc28d1f448f..53c82f9901ebaa6a887cb7d4ee76abcbda5e66ce 100644 (file)
@@ -13,17 +13,17 @@ https://gitlab.alpinelinux.org/alpine/aports/commit/76b81b486480fd9c3294cd420bcf
 
 --- a/qga/commands-posix.c
 +++ b/qga/commands-posix.c
-@@ -74,6 +74,7 @@ static void ga_wait_child(pid_t pid, int
- void qmp_guest_shutdown(bool has_mode, const char *mode, Error **errp)
+@@ -76,6 +76,7 @@ static void ga_wait_child(pid_t pid, int
+ void qmp_guest_shutdown(const char *mode, Error **errp)
  {
      const char *shutdown_flag;
 +    const char *fallback_cmd = NULL;
      Error *local_err = NULL;
      pid_t pid;
      int status;
-@@ -95,10 +96,13 @@ void qmp_guest_shutdown(bool has_mode, c
+@@ -97,10 +98,13 @@ void qmp_guest_shutdown(const char *mode
      slog("guest-shutdown called, mode: %s", mode);
-     if (!has_mode || strcmp(mode, "powerdown") == 0) {
+     if (!mode || strcmp(mode, "powerdown") == 0) {
          shutdown_flag = powerdown_flag;
 +        fallback_cmd = "/sbin/poweroff";
      } else if (strcmp(mode, "halt") == 0) {
@@ -35,7 +35,7 @@ https://gitlab.alpinelinux.org/alpine/aports/commit/76b81b486480fd9c3294cd420bcf
      } else {
          error_setg(errp,
                     "mode is invalid (valid values are: halt|powerdown|reboot");
-@@ -123,6 +127,7 @@ void qmp_guest_shutdown(bool has_mode, c
+@@ -125,6 +129,7 @@ void qmp_guest_shutdown(const char *mode
          execl("/sbin/shutdown", "shutdown", "-h", shutdown_flag, "+0",
                 "hypervisor initiated shutdown", (char *)NULL);
  #endif
index e8bfe84c6e9f3a073ffa5c70af7024e24aa01be8..c5e99a1bffc71ddd4189d6e912804928c1d6188a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/meson.build
 +++ b/meson.build
-@@ -3142,10 +3142,6 @@ subdir('common-user')
+@@ -3191,10 +3191,6 @@ subdir('common-user')
  subdir('bsd-user')
  subdir('linux-user')
  
@@ -11,7 +11,7 @@
  # accel modules
  tcg_real_module_ss = ss.source_set()
  tcg_real_module_ss.add_all(when: 'CONFIG_TCG_MODULAR', if_true: tcg_module_ss)
-@@ -3633,10 +3629,6 @@ subdir('scripts')
+@@ -3682,10 +3678,6 @@ subdir('scripts')
  subdir('tools')
  subdir('pc-bios')
  subdir('docs')