uboot-envtools: add support for Aruba AP-303 and AP-365
authorJan Alexander <jan@nalx.net>
Sat, 9 Jan 2021 10:33:34 +0000 (11:33 +0100)
committerDavid Bauer <mail@david-bauer.net>
Thu, 14 Jan 2021 00:04:02 +0000 (01:04 +0100)
Both devices use u-boot env variables to boot OpenWrt from its flash
partition. Using u-boot envtools, it is possible to change the bootcmd
back to the stock firmware partition directly from OpenWrt without
attaching a serial cable or even physically accessing the device.

Signed-off-by: Jan Alexander <jan@nalx.net>
package/boot/uboot-envtools/files/ipq40xx
target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4029-ap-303.dts
target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4029-ap-365.dts
target/linux/ipq40xx/image/Makefile

index 8a0de7a548b6583ef768286d3f09009d9ddf0bb6..b24cbf979e7c9e42525da5262d02b592dfdf478b 100644 (file)
@@ -43,6 +43,12 @@ plasmacloud,pa1200 |\
 plasmacloud,pa2200)
        ubootenv_add_uci_config "/dev/mtd5" "0x0" "0x10000" "0x10000"
        ;;
+aruba,ap-303)
+       ubootenv_add_uci_config "/dev/mtd13" "0x0" "0x10000" "0x10000"
+       ;;
+aruba,ap-365)
+       ubootenv_add_uci_config "/dev/mtd8" "0x0" "0x10000" "0x10000"
+       ;;
 buffalo,wtr-m2133hp)
        ubootenv_add_uci_config "/dev/mtd8" "0x0" "0x40000" "0x20000"
        ;;
index a3cecddd6eee6b4018f9d2066b3aafef6fbd934e..13f89d810c193212cb9881115bcb4e2c137945eb 100644 (file)
                        };
 
                        partition@380000 {
-                               /* This is empty */
                                label = "appsblenv";
                                reg = <0x380000 0x10000>;
-                               read-only;
                        };
 
                        partition@390000 {
index 1d4e50292e685b5cde228f672a59da8a2ca3fb00..988a4421b5baa8bfe9995a5d38118817e8951800 100644 (file)
                        partition@e0000 {
                                label = "u-boot-env";
                                reg = <0xe0000 0x10000>;
-                               read-only;
                        };
 
                        partition@f0000 {
index c19dcb40397d3211db041275bbc3fce302ab0d1a..f10ff002dc65cd7631603e21bdd745ef3f9b1daa 100644 (file)
@@ -156,6 +156,7 @@ endef
 define Device/aruba_ap-303
        $(call Device/aruba_glenmorangie)
        DEVICE_MODEL := AP-303
+       DEVICE_PACKAGES += uboot-envtools
 endef
 TARGET_DEVICES += aruba_ap-303
 
@@ -168,7 +169,7 @@ TARGET_DEVICES += aruba_ap-303h
 define Device/aruba_ap-365
        $(call Device/aruba_glenmorangie)
        DEVICE_MODEL := AP-365
-       DEVICE_PACKAGES += kmod-hwmon-ad7418
+       DEVICE_PACKAGES += kmod-hwmon-ad7418 uboot-envtools
 endef
 TARGET_DEVICES += aruba_ap-365