nut: add cable type nut driver config 18516/head
authorRob J. Epping <epping@renf.us>
Wed, 11 May 2022 21:17:06 +0000 (23:17 +0200)
committerRob J. Epping <epping@renf.us>
Fri, 13 May 2022 04:53:27 +0000 (06:53 +0200)
at least driver apcsmart-old (maybe more) allow for specifying the
type of cable used. My old UPS does will not function when cable type
is not specified.

This will add support for configuration option 'cable'

Signed-off-by: Rob J. Epping <epping@renf.us>
net/nut/Makefile
net/nut/files/nut-server.init

index 859da030c7dafd9d58662a901b26dcc907f75db4..bc69d2277fa3b7aba0800e7063401b9caa091e22 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nut
 PKG_VERSION:=2.7.4
-PKG_RELEASE:=27
+PKG_RELEASE:=28
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.networkupstools.org/source/2.7/
index f9178ba9f1b6690a49358966f3e7ce96ae6d7ce8..70cb21f8713eb857ea49071bef83e772426b2b63 100755 (executable)
@@ -147,6 +147,7 @@ build_driver_config() {
        echo "[$cfg]" >>"$UPS_C"
 
        get_write_driver_config "$cfg" bus
+       get_write_driver_config "$cfg" cable
        get_write_driver_config "$cfg" community
        get_write_driver_config "$cfg" desc
        get_write_driver_config "$cfg" driver "usbhid-ups"