diffutils: fix 'compilation error on x86_64 6288/head
authorSébastien Delafond <sdelafond@gmail.com>
Wed, 13 Jun 2018 16:15:26 +0000 (18:15 +0200)
committerSébastien Delafond <sdelafond@gmail.com>
Wed, 13 Jun 2018 16:15:26 +0000 (18:15 +0200)
Here was the first error I got:

  xstrtol-error.c:84:26: error: invalid use of undefined type 'struct
  rpl_option'

More information on this error here:
  https://www.mail-archive.com/clfs-support@lists.clfs.org/msg00297.html

I'm not sure if this is an issue in my build environment, but I believe
this is the proper fix because gzip and zile use the same option:

  ./utils/gzip/Makefile: gl_cv_func_getopt_gnu=yes \
  ./utils/zile/Makefile: gl_cv_func_getopt_gnu=yes \

This commit is mostly a reformat/sign-off of previous work by Dirk
Morris <dmorris@untangle.com>

Signed-off-by: Sébastien Delafond <sdelafond@gmail.com>
devel/diffutils/Makefile

index 643eaf9a1f026b7e666b479e94413b34373f2254..8465d86657e952834e90da2cac22cbc7eaca8462 100644 (file)
@@ -35,6 +35,7 @@ define Package/diffutils/description
 endef
 
 CONFIGURE_VARS += \
+       gl_cv_func_getopt_gnu=yes \
        ac_cv_func_mempcpy=n
 TARGET_CFLAGS += --std=gnu99