strongswan: add kernel module dependency on chapoly 18654/head
authorPhilip Prindeville <philipp@redfish-solutions.com>
Wed, 1 Jun 2022 00:41:28 +0000 (18:41 -0600)
committerPhilip Prindeville <philipp@redfish-solutions.com>
Wed, 1 Jun 2022 00:42:32 +0000 (18:42 -0600)
Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
net/strongswan/Makefile

index 3cb1c94a675f4a2cf01ff0960b1f528651ed561d..b202fb358e2d1ffc3a6eb158954d1794382e452e 100644 (file)
@@ -668,7 +668,7 @@ $(eval $(call BuildPlugin,attr-sql,SQL based config,+strongswan-charon))
 $(eval $(call BuildPlugin,bliss,BLISS crypto,+strongswan-libnttfft +strongswan-mod-mgf1 +strongswan-mod-hmac))
 $(eval $(call BuildPlugin,blowfish,Blowfish crypto,))
 $(eval $(call BuildPlugin,ccm,CCM AEAD wrapper crypto,))
-$(eval $(call BuildPlugin,chapoly,ChaCha20-Poly1305 AEAD crypto,))
+$(eval $(call BuildPlugin,chapoly,ChaCha20-Poly1305 AEAD crypto,+kmod-crypto-chacha20poly1305))
 $(eval $(call BuildPlugin,cmac,CMAC crypto,))
 $(eval $(call BuildPlugin,connmark,netfilter connection marking,+libip4tc))
 $(eval $(call BuildPlugin,constraints,advanced X509 constraint checking,))