libftdi: Fix compilation with most recent CMake 8996/head
authorRosen Penev <rosenp@gmail.com>
Wed, 15 May 2019 21:43:14 +0000 (14:43 -0700)
committerRosen Penev <rosenp@gmail.com>
Thu, 16 May 2019 00:27:02 +0000 (17:27 -0700)
Description from Amol Bhave:

This package fails to compile with boost 1.70 when the boost cmake
config gets used.
As far as I can tell, Boost 1.70 introduced
BoostConfigVersion.cmake. In that file, the value of PACKAGE_VERSION is
set to 1.70. This makes CMake auto set the variable Boost_VERSION to
1.70. Historically, Boost_VERSION has been using the format like 170000,
and not 1.70. Some package cmake files still depend on this behavior
and make assertions such as Boost_VERSION > 168000. This is incompatible
with the new scheme.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
libs/libftdi/Makefile

index ba9b09a4531eb5cf30bc55038ffdba619502334d..4cdb0166d48bc4609dfce59fd467bfb3913d55f2 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libftdi
 PKG_VERSION:=0.20
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.intra2net.com/en/developer/libftdi/download/
@@ -39,6 +39,8 @@ define Package/libftdi/description
   The library is linked with your program in userspace, no kernel driver required.
 endef
 
+CMAKE_OPTIONS += -DBoost_NO_BOOST_CMAKE=ON
+
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/
        $(CP) $(PKG_INSTALL_DIR)/usr/include/ftdi.h $(1)/usr/include/