xfrpc: update to version 2.9.644
authorDengfeng Liu <liudf0716@gmail.com>
Fri, 22 Sep 2023 03:40:23 +0000 (03:40 +0000)
committerTianling Shen <cnsztl@gmail.com>
Sat, 23 Sep 2023 04:17:45 +0000 (12:17 +0800)
Release notes:
https://github.com/liudf0716/xfrpc/releases/tag/2.9.644

Signed-off-by: Dengfeng Liu <liudf0716@gmail.com>
net/xfrpc/Makefile
net/xfrpc/files/xfrpc.init

index d25c6b01c1a9f609a54e37c181473567dd9ad6c5..684bb84fb157d4f57a2e4b8f05ee57e13ded2ef4 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=xfrpc
-PKG_VERSION:=2.6.633
+PKG_VERSION:=2.9.644
 PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/liudf0716/xfrpc.git
 PKG_SOURCE_VERSION:=$(PKG_VERSION)
-PKG_MIRROR_HASH:=b9d5c2f8dd0d323169a824bb59d65bcc27fe6e0564c6aede5b966220b99ccc7b
+PKG_MIRROR_HASH:=99cda337c641664d94abc3fe4e144c13a7f3191951e917e7a837ab88a7df4515
 
 PKG_MAINTAINER:=Dengfeng Liu <liudf0716@gmail.com>
 PKG_LICENSE:=GPL-3.0-or-later
index 3b0ddedafca7d8d6d40365eb85736715ae1cb2ad..cc803b0a27dd63e2d78821caea55aeb3a5b7cc1d 100755 (executable)
@@ -28,7 +28,7 @@ handle_xfrpc() {
                echo "local_ip = $local_ip" >> "$config"
                echo "local_port = $local_port" >> "$config"
                case "$type" in
-               tcp)
+               tcp|mstsc|socks5)
                        config_get remote_port "$name" remote_port
                        echo "remote_port = $remote_port" >> "$config"
                        ;;