openldap: udpate to 2.6.0
authorW. Michael Petullo <mike@flyn.org>
Sun, 12 Dec 2021 20:28:18 +0000 (14:28 -0600)
committerRosen Penev <rosenp@gmail.com>
Tue, 14 Dec 2021 03:56:44 +0000 (19:56 -0800)
Signed-off-by: W. Michael Petullo <mike@flyn.org>
libs/openldap/Makefile
libs/openldap/patches/001-automake-compat.patch
libs/openldap/patches/002-no-doc-and-tests-subdir.patch
libs/openldap/patches/750-no-strip.patch
libs/openldap/patches/800-implicit.patch [deleted file]
libs/openldap/patches/901-reduce-slapd-default-mem-usage.patch

index 426693c8f9b2216541e4c6e6837b35f98bafbd17..2a3a456bf0e8373550db47c743a3de3aefe2a486 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openldap
-PKG_VERSION:=2.4.58
+PKG_VERSION:=2.6.0
 PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
@@ -16,13 +16,20 @@ PKG_SOURCE_URL:=https://gpl.savoirfairelinux.net/pub/mirrors/openldap/openldap-r
        http://mirror.eu.oneandone.net/software/openldap/openldap-release/ \
        http://mirror.switch.ch/ftp/software/mirror/OpenLDAP/openldap-release/ \
        https://www.openldap.org/software/download/OpenLDAP/openldap-release/
-PKG_HASH:=57b59254be15d0bf6a9ab3d514c1c05777b02123291533134a87c94468f8f47b
+PKG_HASH:=b71c580eac573e9aba15d95f33dd4dd08f2ed4f0d7fc09e08ad4be7ed1e41a4f
 PKG_LICENSE:=OLDAP-2.8
 PKG_LICENSE_FILES:=LICENSE
 PKG_CPE_ID:=cpe:/a:openldap:openldap
 
 PKG_FIXUP:=autoreconf
 
+# Fixes the following:
+# libtool: Version mismatch error.  This is libtool 2.4.2, but the
+# libtool: definition of this LT_INIT comes from libtool 2.4.6.
+# libtool: You should recreate aclocal.m4 with macros from libtool 2.4.2
+# libtool: and run autoconf again.
+PKG_REMOVE_FILES:=build/ltversion.m4
+
 PKG_CONFIG_DEPENDS := \
         CONFIG_OPENLDAP_DEBUG \
         CONFIG_OPENLDAP_CRYPT \
@@ -44,7 +51,7 @@ endef
 define Package/libopenldap
   $(call Package/libopenldap/Default)
   MENU:=1
-  DEPENDS:=+libopenssl +libsasl2 +libpthread +OPENLDAP_DB47:libdb47 +OPENLDAP_ICU:icu
+  DEPENDS:=+libopenssl +libsasl2 +libpthread +libuuid +OPENLDAP_DB47:libdb47 +OPENLDAP_ICU:icu
   TITLE+= (libraries)
 endef
 
index c6a9ed89eebae88ce87ed0e31e1497e92f51f0f2..c1d4e86dab80a867c92dccd492de3c14e99b1317 100644 (file)
@@ -1,18 +1,14 @@
---- /dev/null
-+++ b/Makefile.am
-@@ -0,0 +1 @@
-+SUBDIRS = include libraries clients servers tests doc
---- a/libraries/Makefile.in
-+++ b/libraries/Makefile.in
+--- a/clients/tools/Makefile.in
++++ b/clients/tools/Makefile.in
 @@ -13,6 +13,8 @@
  ## top-level directory of the distribution or, alternatively, at
  ## <http://www.OpenLDAP.org/license.html>.
  
 +SHELL = @SHELL@
 +
- SUBDIRS= \
-       liblutil \
-       liblber \
+ SRCS  = ldapsearch.c ldapmodify.c ldapdelete.c ldapmodrdn.c \
+               ldappasswd.c ldapwhoami.c ldapvc.c ldapcompare.c \
+               ldapexop.c ldapurl.c common.c
 --- a/libraries/liblber/Makefile.in
 +++ b/libraries/liblber/Makefile.in
 @@ -13,6 +13,8 @@
 +
  LIBRARY = libldap.la
  
- PROGRAMS = apitest dntest ftest ltest urltest
---- a/libraries/libldap_r/Makefile.in
-+++ b/libraries/libldap_r/Makefile.in
-@@ -13,6 +13,8 @@
- ## top-level directory of the distribution or, alternatively, at
- ## <http://www.OpenLDAP.org/license.html>.
-+SHELL = @SHELL@
-+
- LIBRARY = libldap_r.la
- PROGRAMS = apitest ltest
+ PROGRAMS = apitest dntest ftest ltest urltest testavl
 --- a/libraries/liblunicode/Makefile.in
 +++ b/libraries/liblunicode/Makefile.in
 @@ -13,6 +13,8 @@
@@ -66,8 +51,8 @@
 +SHELL = @SHELL@
 +
  LIBRARY       = liblutil.a
- PROGRAM = testavl
  
+ LDAP_INCDIR= ../../include       
 --- a/libraries/librewrite/Makefile.in
 +++ b/libraries/librewrite/Makefile.in
 @@ -16,6 +16,8 @@
  SRCS = config.c context.c info.c ldapmap.c map.c params.c rule.c \
        session.c subst.c var.c xmap.c \
        parse.c rewrite.c
---- a/clients/tools/Makefile.in
-+++ b/clients/tools/Makefile.in
-@@ -13,6 +13,8 @@
- ## top-level directory of the distribution or, alternatively, at
- ## <http://www.OpenLDAP.org/license.html>.
-+SHELL = @SHELL@
-+
- SRCS  = ldapsearch.c ldapmodify.c ldapdelete.c ldapmodrdn.c \
-               ldappasswd.c ldapwhoami.c ldapcompare.c \
-               ldapexop.c ldapurl.c common.c
---- a/servers/slapd/Makefile.in
-+++ b/servers/slapd/Makefile.in
+--- a/libraries/Makefile.in
++++ b/libraries/Makefile.in
 @@ -13,6 +13,8 @@
  ## top-level directory of the distribution or, alternatively, at
  ## <http://www.OpenLDAP.org/license.html>.
  
 +SHELL = @SHELL@
 +
- SLAPTOOLS=slapadd slapcat slapdn slapindex slappasswd slaptest slapauth slapacl slapschema
- PROGRAMS=slapd $(SLAPTOOLS)
- XPROGRAMS=sslapd libbackends.a .backend liboverlays.a
---- a/servers/slapd/overlays/Makefile.in
-+++ b/servers/slapd/overlays/Makefile.in
-@@ -13,6 +13,8 @@
+ SUBDIRS= \
+       liblutil \
+       liblber \
+--- a/servers/lloadd/Makefile.in
++++ b/servers/lloadd/Makefile.in
+@@ -13,6 +13,7 @@
  ## top-level directory of the distribution or, alternatively, at
  ## <http://www.OpenLDAP.org/license.html>.
  
 +SHELL = @SHELL@
-+
- SRCS = overlays.c \
-       accesslog.c \
-       auditlog.c \
---- a/tests/progs/Makefile.in
-+++ b/tests/progs/Makefile.in
-@@ -13,6 +13,8 @@
- ## top-level directory of the distribution or, alternatively, at
- ## <http://www.OpenLDAP.org/license.html>.
  
-+SHELL = @SHELL@
-+
- PROGRAMS = slapd-tester slapd-search slapd-read slapd-addel slapd-modrdn \
-               slapd-modify slapd-bind slapd-mtread ldif-filter
+ XSRCS = version.c
  
---- a/servers/slapd/back-bdb/Makefile.in
-+++ b/servers/slapd/back-bdb/Makefile.in
-@@ -13,6 +13,8 @@
- ## top-level directory of the distribution or, alternatively, at
- ## <http://www.OpenLDAP.org/license.html>.
+--- a/servers/slapd/back-asyncmeta/Makefile.in
++++ b/servers/slapd/back-asyncmeta/Makefile.in
+@@ -19,6 +19,8 @@
+ ## based on back-meta module for inclusion in OpenLDAP Software.
+ ## This work was sponsored by Ericsson
  
 +SHELL = @SHELL@
 +
- SRCS = init.c tools.c config.c \
-       add.c bind.c compare.c delete.c modify.c modrdn.c search.c \
-       extended.c referral.c operational.c \
+ SRCS  = init.c config.c search.c message_queue.c bind.c add.c compare.c \
+               delete.c modify.c modrdn.c map.c \
+               conn.c candidates.c dncache.c meta_result.c
 --- a/servers/slapd/back-dnssrv/Makefile.in
 +++ b/servers/slapd/back-dnssrv/Makefile.in
 @@ -18,6 +18,8 @@
  SRCS  = init.c bind.c search.c config.c referral.c
  OBJS  = init.lo bind.lo search.lo config.lo referral.lo
  
---- a/servers/slapd/back-hdb/Makefile.in
-+++ b/servers/slapd/back-hdb/Makefile.in
-@@ -15,6 +15,8 @@
- #
- ## Copyright 2003 Howard Chu @ Symas Corp. See master COPYRIGHT file for terms.
-+SHELL = @SHELL@
-+
- XXDIR = $(srcdir)/../back-bdb
- XXSRCS = init.c tools.c config.c \
 --- a/servers/slapd/back-ldap/Makefile.in
 +++ b/servers/slapd/back-ldap/Makefile.in
 @@ -13,6 +13,8 @@
  SRCS = init.c search.c compare.c modify.c bind.c \
        operational.c \
        cache.c entry.c \
---- a/servers/slapd/back-ndb/Makefile.in
-+++ b/servers/slapd/back-ndb/Makefile.in
-@@ -17,6 +17,8 @@
- ## This work was initially developed by Howard Chu for inclusion
- ## in OpenLDAP Software. This work was sponsored by MySQL.
-+SHELL = @SHELL@
-+
- SRCS = init.cpp tools.cpp config.cpp ndbio.cpp \
-       add.cpp bind.cpp compare.cpp delete.cpp modify.cpp modrdn.cpp search.cpp
 --- a/servers/slapd/back-null/Makefile.in
 +++ b/servers/slapd/back-null/Makefile.in
 @@ -13,6 +13,8 @@
  SRCS  = init.c op.c
  OBJS  = init.lo op.lo
  
---- a/servers/slapd/back-shell/Makefile.in
-+++ b/servers/slapd/back-shell/Makefile.in
-@@ -13,6 +13,8 @@
- ## top-level directory of the distribution or, alternatively, at
- ## <http://www.OpenLDAP.org/license.html>.
-+SHELL = @SHELL@
-+
- SRCS  = init.c config.c fork.c search.c bind.c unbind.c add.c \
-               delete.c modify.c modrdn.c compare.c result.c
- OBJS  = init.lo config.lo fork.lo search.lo bind.lo unbind.lo add.lo \
 --- a/servers/slapd/back-sock/Makefile.in
 +++ b/servers/slapd/back-sock/Makefile.in
 @@ -17,6 +17,8 @@
  SRCS  = init.c config.c search.c bind.c compare.c operational.c \
                entry-id.c schema-map.c sql-wrap.c modify.c util.c \
                add.c delete.c modrdn.c api.c
---- a/servers/slapd/shell-backends/Makefile.in
-+++ b/servers/slapd/shell-backends/Makefile.in
+--- a/servers/slapd/back-wt/Makefile.in
++++ b/servers/slapd/back-wt/Makefile.in
+@@ -13,6 +13,8 @@
+ ## top-level directory of the distribution or, alternatively, at
+ ## <http://www.OpenLDAP.org/license.html>.
++SHELL = @SHELL@
++
+ SRCS = init.c tools.c config.c \
+        add.c bind.c compare.c delete.c modify.c modrdn.c search.c \
+        extended.c operational.c \
+--- a/servers/slapd/Makefile.in
++++ b/servers/slapd/Makefile.in
+@@ -13,6 +13,8 @@
+ ## top-level directory of the distribution or, alternatively, at
+ ## <http://www.OpenLDAP.org/license.html>.
++SHELL = @SHELL@
++
+ SLAPTOOLS=slapadd slapcat slapdn slapindex slapmodify slappasswd slaptest slapauth slapacl slapschema
+ PROGRAMS=slapd $(SLAPTOOLS)
+ XPROGRAMS=sslapd libbackends.a .backend liboverlays.a
+--- a/servers/slapd/overlays/Makefile.in
++++ b/servers/slapd/overlays/Makefile.in
 @@ -13,6 +13,8 @@
  ## top-level directory of the distribution or, alternatively, at
  ## <http://www.OpenLDAP.org/license.html>.
  
 +SHELL = @SHELL@
 +
- PROGRAMS = passwd-shell
+ SRCS = overlays.c \
+       accesslog.c \
+       auditlog.c \
+--- a/servers/slapd/pwmods/Makefile.in
++++ b/servers/slapd/pwmods/Makefile.in
+@@ -13,6 +13,8 @@
+ ## top-level directory of the distribution or, alternatively, at
+ ## <http://www.OpenLDAP.org/license.html>.
  
- SRCS = passwd-shell.c shellutil.c
++SHELL = @SHELL@
++
+ SRCS = argon2.c
+ LTONLY_MOD = $(LTONLY_mod)
 --- a/servers/slapd/slapi/Makefile.in
 +++ b/servers/slapd/slapi/Makefile.in
 @@ -14,6 +14,8 @@
  LIBRARY = libslapi.la
  
  #all-common: $(LIBRARY) $(PROGRAMS)
+--- a/tests/progs/Makefile.in
++++ b/tests/progs/Makefile.in
+@@ -13,6 +13,8 @@
+ ## top-level directory of the distribution or, alternatively, at
+ ## <http://www.OpenLDAP.org/license.html>.
++SHELL = @SHELL@
++
+ PROGRAMS = slapd-tester slapd-search slapd-read slapd-addel slapd-modrdn \
+               slapd-modify slapd-bind slapd-mtread ldif-filter slapd-watcher
index 5d8c93eefc2acc19bf7a2c51fd7aa3d0365e4c8c..1af97593e51b918c3d8ff9b062a05e94e1e27e41 100644 (file)
@@ -1,5 +1,11 @@
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -1 +1 @@
--SUBDIRS = include libraries clients servers tests doc
-+SUBDIRS = include libraries clients servers
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -13,7 +13,7 @@
+ ## top-level directory of the distribution or, alternatively, at
+ ## <http://www.OpenLDAP.org/license.html>.
+-SUBDIRS= include libraries clients servers tests doc
++SUBDIRS= include libraries clients servers
+ CLEANDIRS=
+ INSTALLDIRS= 
index a70aacc9029614bee6cc0b599a1813a8ae5587e8..8cffb4f56744b76163a99bebda3862b26cb9fc0c 100644 (file)
@@ -1,21 +1,21 @@
 --- a/clients/tools/Makefile.in
 +++ b/clients/tools/Makefile.in
-@@ -122,7 +122,7 @@ install-local:     FORCE
+@@ -131,7 +131,7 @@ install-local:     FORCE
        -$(MKDIR) $(DESTDIR)$(bindir)
        @(                                                              \
            for prg in $(PROGRAMS); do                                  \
--              $(LTINSTALL) $(INSTALLFLAGS) $(STRIP) -m 755 $$prg$(EXEEXT)     \
+-              $(LTINSTALL) $(INSTALLFLAGS) $(STRIP_OPTS) -m 755 $$prg$(EXEEXT)        \
 +              $(LTINSTALL) $(INSTALLFLAGS) -m 755 $$prg$(EXEEXT)      \
                    $(DESTDIR)$(bindir);                                \
            done                                                        \
        )
 --- a/servers/slapd/Makefile.in
 +++ b/servers/slapd/Makefile.in
-@@ -380,7 +380,7 @@ install-local-srv: install-slapd install
+@@ -377,7 +377,7 @@ install-local-srv: install-slapd install
  install-slapd: FORCE
        -$(MKDIR) $(DESTDIR)$(libexecdir)
        -$(MKDIR) $(DESTDIR)$(localstatedir)/run
--      $(LTINSTALL) $(INSTALLFLAGS) $(STRIP) -m 755 \
+-      $(LTINSTALL) $(INSTALLFLAGS) $(STRIP_OPTS) -m 755 \
 +      $(LTINSTALL) $(INSTALLFLAGS) -m 755 \
                slapd$(EXEEXT) $(DESTDIR)$(libexecdir)
        @for i in $(SUBDIRS); do \
diff --git a/libs/openldap/patches/800-implicit.patch b/libs/openldap/patches/800-implicit.patch
deleted file mode 100644 (file)
index aa7e294..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/libraries/libldap/tls2.c
-+++ b/libraries/libldap/tls2.c
-@@ -41,6 +41,7 @@ static tls_impl *tls_imp = &ldap_int_tls
- #define HAS_TLS( sb ) ber_sockbuf_ctrl( sb, LBER_SB_OPT_HAS_IO, \
-                               (void *)tls_imp->ti_sbio )
-+static int ldap_pvt_tls_check_hostname( LDAP *ld, void *s, const char *name_in );
- #endif /* HAVE_TLS */
- #ifdef LDAP_DEVEL
index 0c4dd34a8544e857b5ac6fcf093f5baa52e9ce76..46818718bb94720cb0addbb783ac695f52d11a07 100644 (file)
@@ -1,6 +1,6 @@
 --- a/servers/slapd/slapd.conf
 +++ b/servers/slapd/slapd.conf
-@@ -50,7 +50,7 @@ argsfile     %LOCALSTATEDIR%/run/slapd.args
+@@ -59,7 +59,7 @@ database config
  #######################################################################
  
  database      mdb