minidlna: decrease minidlna log verbosity 5567/head
authorPavel Kubelun <be.dissent@gmail.com>
Sun, 4 Feb 2018 12:02:22 +0000 (15:02 +0300)
committerPavel Kubelun <be.dissent@gmail.com>
Sat, 17 Feb 2018 16:29:45 +0000 (11:29 -0500)
Some clients do not close connections properly or do not keep
it alive, so each time the connection times out a corresponding
log entry is written into a log. These messages may spam the log
really hard.
This may be an issue if log is placed on internal flash - it may
prematurely wear a flash chip. This also prevents hdd from spinning
down if the log is located on hdd and the dlna capable tv is online.

Set the log level to "error" by default.

MAN:
Set this to change the verbosity of the information that is logged
each  section can use a different level: off, fatal, error, warn,
info, or debug
Example
log_level=general,artwork,database,inotify,scanner,metadata,http,ssdp,tivo=warn

Signed-off-by: Pavel Kubelun <be.dissent@gmail.com>
multimedia/minidlna/Makefile
multimedia/minidlna/files/minidlna.init

index 5b84a8cbb5e047319561d3fd999826d8fcc4cb31..fc80e56660e32594742a69dc7bd3e2e16ef0560d 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=minidlna
 PKG_VERSION:=1.2.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE_URL:=@SF/minidlna
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
index 79be8f625a05490de2192306282eee387c90c121..c894186d342cd440d812c8ec0d431ef54c0eae86 100644 (file)
@@ -57,6 +57,7 @@ minidlna_create_config() {
        minidlna_cfg_addstr $cfg friendly_name
        minidlna_cfg_addstr $cfg db_dir
        minidlna_cfg_addstr $cfg log_dir
+       minidlna_cfg_addstr $cfg log_level 'error'
        minidlna_cfg_addbool $cfg inotify '1'
        minidlna_cfg_addbool $cfg enable_tivo '0'
        minidlna_cfg_addbool $cfg wide_links '0'