libmicrohttpd: build with PIC
authorRosen Penev <rosenp@gmail.com>
Thu, 14 May 2020 07:52:18 +0000 (00:52 -0700)
committerAlexander Couzens <lynxis@fe80.eu>
Mon, 18 May 2020 09:55:05 +0000 (11:55 +0200)
Fixes compilation when linking statically.

Made URL HTTPS.

Moved description section for consistency between packages.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
libs/libmicrohttpd/Makefile

index d17dcc2e9fb5b0b3f8768089688b14bd6666c469..870971cd3370fb004416a00d97ff37df5163929f 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libmicrohttpd
 PKG_VERSION:=0.9.70
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/libmicrohttpd
@@ -28,7 +28,7 @@ define Package/libmicrohttpd/default
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=GNU libmicrohttpd is a library that runs an HTTP server.
-  URL:=http://www.gnu.org/software/libmicrohttpd/
+  URL:=https://www.gnu.org/software/libmicrohttpd/
 endef
 
 define Package/libmicrohttpd-no-ssl
@@ -46,13 +46,19 @@ $(call Package/libmicrohttpd/default)
   PROVIDES:=libmicrohttpd
 endef
 
+define Package/libmicrohttpd/description
+  GNU libmicrohttpd is a small C library that is supposed to make it easy
+  to run an HTTP server as part of another application.
+endef
+
 CONFIGURE_ARGS += \
        --disable-curl \
        --disable-rpath \
        --disable-doc \
        --disable-examples \
        --disable-poll \
-       --enable-epoll
+       --enable-epoll \
+       --with-pic
 
 ifeq ($(BUILD_VARIANT),ssl)
 CONFIGURE_ARGS += \
@@ -64,11 +70,6 @@ CONFIGURE_ARGS += \
        --without-gnutls
 endif
 
-define Package/libmicrohttpd/description
-  GNU libmicrohttpd is a small C library that is supposed to make it easy
-  to run an HTTP server as part of another application.
-endef
-
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/microhttpd.h $(1)/usr/include/