busybox: Let procd respawn cron
authorBruno Randolf <br1@einfach.org>
Mon, 9 Nov 2020 10:43:10 +0000 (10:43 +0000)
committerPetr Štetiar <ynezz@true.cz>
Thu, 12 Nov 2020 17:19:44 +0000 (18:19 +0100)
On some systems I see the issue that crond dies after a few days.
Simply letting procd respawn the process is a simple safety-net.

Signed-off-by: Bruno Randolf <br1@einfach.org>
package/utils/busybox/Makefile
package/utils/busybox/files/cron

index 25db4ff387cfc64e7e79dde37df6f7ab63df9120..71bd888c7192048063149375a000e73c269984ea 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
 PKG_VERSION:=1.31.1
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 PKG_FLAGS:=essential
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
index ca04a0c1707e5880e213d71d60402bbb9ef2720e..4efdfa52cad32b6003c4e341148df52cc47f44ec 100755 (executable)
@@ -32,6 +32,7 @@ start_service() {
        for crontab in /etc/crontabs/*; do
                 procd_set_param file "$crontab"
        done
+       procd_set_param respawn
        procd_close_instance
 }