icecast: Improve OOB experience - new defaults, add user & group ids 1974/head
authorTed Hess <thess@kitschensync.net>
Sun, 15 Nov 2015 18:28:55 +0000 (13:28 -0500)
committerTed Hess <thess@kitschensync.net>
Sun, 15 Nov 2015 18:29:12 +0000 (13:29 -0500)
Signed-off-by: Ted Hess <thess@kitschensync.net>
multimedia/icecast/Makefile
multimedia/icecast/files/icecast.init
multimedia/icecast/patches/020-icecast_config_for_openwrt.patch [new file with mode: 0644]

index 1b0766e7e4655d5937de263a7e3114f7d49b3410..fa0f7d24db9dd461b693bb6ff6bb2181bf2a7923 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=icecast
 PKG_VERSION:=2.4.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_LICENSE:=GPL-2.0
 PKG_MAINTAINER:=AndrĂ© Gaul <andre@gaul.io>
 
@@ -29,6 +29,7 @@ define Package/icecast
   CATEGORY:=Multimedia
   DEPENDS:=+libcurl +libxml2 +libxslt +libogg +libopenssl
   TITLE:=A streaming media server for Ogg/Vorbis and MP3 audio streams
+  USERID:=icecast=87:icecast=87
   URL:=http://www.icecast.org/
 endef
 
index 355e4b7169c35764534ad09ac9ebbed9c67e2778..96b36e1886074923cf23943bc42d1d97eb2ee5c9 100755 (executable)
@@ -1,12 +1,21 @@
 #!/bin/sh /etc/rc.common
-# Example script
-# Copyright (C) 2014 OpenWrt.org
+
+# Startup script
+# Copyright (C) 2015 OpenWrt.org
  
 USE_PROCD=1
-START=99
+START=90
 STOP=15
 
 start_service() {
+       user_exists icecast 87 || user_add icecast 87
+       group_exists icecast 87 || group_add icecast 87
+       
+       [ -d /var/log/icecast ] || {
+               mkdir -m 0755 -p /var/log/icecast
+               chown icecast:icecast /var/log/icecast
+       }
+
        procd_open_instance
        procd_set_param command /usr/bin/icecast -c /etc/icecast.xml
        procd_set_param respawn
diff --git a/multimedia/icecast/patches/020-icecast_config_for_openwrt.patch b/multimedia/icecast/patches/020-icecast_config_for_openwrt.patch
new file mode 100644 (file)
index 0000000..d3282f2
--- /dev/null
@@ -0,0 +1,25 @@
+--- a/conf/icecast.xml.in
++++ b/conf/icecast.xml.in
+@@ -61,7 +61,7 @@
+          It affects mainly the urls generated by Icecast for playlists and yp
+          listings. You MUST configure it properly for YP listings to work!
+     -->
+-    <hostname>localhost</hostname>
++    <hostname>OpenWrt</hostname>
+     <!-- You may have multiple <listener> elements -->
+     <listen-socket>
+@@ -234,11 +234,9 @@
+     <security>
+         <chroot>0</chroot>
+-        <!--
+         <changeowner>
+-            <user>nobody</user>
+-            <group>nogroup</group>
++            <user>icecast</user>
++            <group>icecast</group>
+         </changeowner>
+-        -->
+     </security>
+ </icecast>