avr32: built the firmware images from the lzma compressed uImage
authorGabor Juhos <juhosg@openwrt.org>
Tue, 12 Mar 2013 13:28:16 +0000 (13:28 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Tue, 12 Mar 2013 13:28:16 +0000 (13:28 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 35978

target/linux/avr32/image/Makefile

index 595a5d9fcfa4c4b58205a1853fef966f9d5eebee..11387b14ea5b062604e51d68c33c49254686271d 100644 (file)
@@ -40,14 +40,14 @@ endef
 define Image/Build/squashfs
        $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
        ( \
-               dd if=$(KDIR)/uImage bs=1024k conv=sync; \
+               dd if=$(KDIR)/uImage-lzma bs=1024k conv=sync; \
                dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
        ) > $(BIN_DIR)/$(IMG_PREFIX)-$(1).img
 endef
 
 define Image/Build/jffs2-64k
        ( \
-               dd if=$(KDIR)/uImage bs=1024k conv=sync; \
+               dd if=$(KDIR)/uImage-lzma bs=1024k conv=sync; \
                dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
        ) > $(BIN_DIR)/$(IMG_PREFIX)-$(1).img
 endef