https-dns-proxy: fix restart 20052/head
authorStan Grishin <stangri@melmac.ca>
Sat, 10 Dec 2022 05:32:20 +0000 (05:32 +0000)
committerStan Grishin <stangri@melmac.ca>
Sat, 10 Dec 2022 05:32:20 +0000 (05:32 +0000)
Signed-off-by: Stan Grishin <stangri@melmac.ca>
net/https-dns-proxy/Makefile
net/https-dns-proxy/files/https-dns-proxy.init

index a91a3d1cd72b472c09a3070693981a84f1cc7705..4b519a9b214393ff94a516b2d1b9a425c97ad14e 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=https-dns-proxy
 PKG_VERSION:=2022-10-15
-PKG_RELEASE:=9
+PKG_RELEASE:=10
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/aarond10/https_dns_proxy/
index 201ddadc721824e397c0bd09e6a52c5b522bd51a..0e75a14d78465cafd766d0dde029367f143b86d1 100755 (executable)
@@ -280,7 +280,7 @@ service_triggers() {
 
 service_started() { procd_set_config_changed firewall; }
 service_stopped() { procd_set_config_changed firewall; }
-restart() { procd_send_signal "$packageName"; }
+restart() { procd_send_signal "$packageName"; rc_procd start_service; }
 
 dnsmasq_doh_server() {
        local cfg="$1" param="$2" address="${3:-127.0.0.1}" port="$4" i