ath79: Make patches apply again
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 11 Sep 2022 20:17:47 +0000 (22:17 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 11 Sep 2022 20:17:47 +0000 (22:17 +0200)
The patch adding support for LEDs connected to a reset controller did
not apply any more, refresh it on top of current master.

Fixes: 53fc987b2552 ("generic: move ledbar driver from mediatek target")
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
target/linux/ath79/patches-5.10/0003-leds-add-reset-controller-based-driver.patch
target/linux/ath79/patches-5.15/0003-leds-add-reset-controller-based-driver.patch
target/linux/generic/hack-5.10/800-ubnt-ledbar-driver.patch
target/linux/generic/pending-5.15/020-05-mm-multigenerational-lru-aging.patch
target/linux/generic/pending-5.15/120-Fix-alloc_node_mem_map-with-ARCH_PFN_OFFSET-calcu.patch

index 4a721f2af26a3661ec34ff5d8a3479889d0f5d98..7505f682abadd57e16d10d24c46e3f2e816dfd48 100644 (file)
@@ -13,9 +13,9 @@ Signed-off-by: John Crispin <john@phrozen.org>
 
 --- a/drivers/leds/Kconfig
 +++ b/drivers/leds/Kconfig
-@@ -931,6 +931,17 @@ config LEDS_ACER_A500
- source "drivers/leds/blink/Kconfig"
+@@ -941,6 +941,17 @@ config LEDS_UBNT_LEDBAR
+         To compile this driver as a module, choose M here: the module
+         will be called leds-ubnt-ledbar.
  
 +config LEDS_RESET
 +      tristate "LED support for reset-controller API"
@@ -176,10 +176,10 @@ Signed-off-by: John Crispin <john@phrozen.org>
 +MODULE_ALIAS("platform:leds-reset");
 --- a/drivers/leds/Makefile
 +++ b/drivers/leds/Makefile
-@@ -93,6 +93,7 @@ obj-$(CONFIG_LEDS_TURRIS_OMNIA)              += leds
- obj-$(CONFIG_LEDS_WM831X_STATUS)      += leds-wm831x-status.o
+@@ -94,6 +94,7 @@ obj-$(CONFIG_LEDS_WM831X_STATUS)     += leds
  obj-$(CONFIG_LEDS_WM8350)             += leds-wm8350.o
  obj-$(CONFIG_LEDS_WRAP)                       += leds-wrap.o
+ obj-$(CONFIG_LEDS_UBNT_LEDBAR)                += leds-ubnt-ledbar.o
 +obj-$(CONFIG_LEDS_RESET)              += leds-reset.o
  
  # LED SPI Drivers
index 7122756c526687e46d9565fbb0e16fe06f319cef..f958e79608ac9fcc578c5439793541a6557b2ce9 100644 (file)
@@ -13,9 +13,9 @@ Signed-off-by: John Crispin <john@phrozen.org>
 
 --- a/drivers/leds/Kconfig
 +++ b/drivers/leds/Kconfig
-@@ -876,6 +876,17 @@ source "drivers/leds/blink/Kconfig"
- comment "Flash and Torch LED drivers"
- source "drivers/leds/flash/Kconfig"
+@@ -886,6 +886,17 @@ config LEDS_UBNT_LEDBAR
+         To compile this driver as a module, choose M here: the module
+         will be called leds-ubnt-ledbar.
  
 +config LEDS_RESET
 +      tristate "LED support for reset-controller API"
@@ -176,10 +176,10 @@ Signed-off-by: John Crispin <john@phrozen.org>
 +MODULE_ALIAS("platform:leds-reset");
 --- a/drivers/leds/Makefile
 +++ b/drivers/leds/Makefile
-@@ -87,6 +87,7 @@ obj-$(CONFIG_LEDS_TURRIS_OMNIA)              += leds
- obj-$(CONFIG_LEDS_WM831X_STATUS)      += leds-wm831x-status.o
+@@ -88,6 +88,7 @@ obj-$(CONFIG_LEDS_WM831X_STATUS)     += leds
  obj-$(CONFIG_LEDS_WM8350)             += leds-wm8350.o
  obj-$(CONFIG_LEDS_WRAP)                       += leds-wrap.o
+ obj-$(CONFIG_LEDS_UBNT_LEDBAR)                += leds-ubnt-ledbar.o
 +obj-$(CONFIG_LEDS_RESET)              += leds-reset.o
  
  # LED SPI Drivers
index 92264eedf9cc4b32ce2ffb480f2fa628761d2245..2b4baab456a0002ac9718fb0c9b5d4ca6ca3ac9d 100644 (file)
@@ -1,8 +1,8 @@
 --- a/drivers/leds/Kconfig
 +++ b/drivers/leds/Kconfig
-@@ -929,6 +929,16 @@ config LEDS_ACER_A500
-         This option enables support for the Power Button LED of
-         Acer Iconia Tab A500.
+@@ -931,6 +931,16 @@ config LEDS_ACER_A500
+ source "drivers/leds/blink/Kconfig"
  
 +config LEDS_UBNT_LEDBAR
 +      tristate "LED support for Ubiquiti UniFi 6 LR"
index e5622ccbbe6d2ad0bb32c64f8a1d5cd040e9a5a6..6fc93d9422fc70508b9cd61b091327499cd39744 100644 (file)
@@ -168,7 +168,7 @@ Change-Id: I3ae8abc3100d023cecb3a699d86020ae6fc10a45
  
  #include <asm/tlbflush.h>
  
-@@ -790,6 +791,13 @@ static bool page_referenced_one(struct p
+@@ -793,6 +794,13 @@ static bool page_referenced_one(struct p
                }
  
                if (pvmw.pte) {
index 4e347a467104254568d91dbd4c8f5d45005a2198..b0b399a2dd6c9756301e87e8fc8e83f1b0ca0359 100644 (file)
@@ -71,7 +71,7 @@ Signed-off-by: Tobias Wolf <dev-NTEO@vplace.de>
 
 --- a/mm/page_alloc.c
 +++ b/mm/page_alloc.c
-@@ -7556,7 +7556,7 @@ static void __init alloc_node_mem_map(st
+@@ -7557,7 +7557,7 @@ static void __init alloc_node_mem_map(st
        if (pgdat == NODE_DATA(0)) {
                mem_map = NODE_DATA(0)->node_mem_map;
                if (page_to_pfn(mem_map) != pgdat->node_start_pfn)