lvm2: update to 2.03.08 11509/head
authorRosen Penev <rosenp@gmail.com>
Thu, 5 Mar 2020 04:02:09 +0000 (20:02 -0800)
committerRosen Penev <rosenp@gmail.com>
Thu, 5 Mar 2020 04:21:30 +0000 (20:21 -0800)
Add PKG_BUILD_PARALLEL for faster compilation.

Replace '  ' with TAB for consistency between packages.

Refresh patches and remove outdated ones.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
utils/lvm2/Makefile
utils/lvm2/patches/000-compile.patch [deleted file]
utils/lvm2/patches/001-include_fix.patch [deleted file]
utils/lvm2/patches/002-const-stdio.patch
utils/lvm2/patches/004-device-include-goto-lable-as-well.patch

index 261235a42c4602fe8dc1381a5a0b2203bf163720..2fa1eda46551b0e3e1d2f1322b401a04044b7f4c 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=LVM2
-PKG_VERSION:=2.03.05
+PKG_VERSION:=2.03.08
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=https://sourceware.org/pub/lvm2
-PKG_HASH:=ca52815c999b20c6d25e3192f142f081b93d01f07b9d787e99664b169dba2700
+PKG_HASH:=6e0261dc9f6ab0ef1fc4a63d105a73e06eb536a273a9d6c2ccc414548c8e1ec8
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME).$(PKG_VERSION)
 
 PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
@@ -22,6 +22,8 @@ PKG_LICENSE:=GPL-2.0 LGPL-2.1
 PKG_LICENSE_FILES:=COPYING COPYING.lib
 PKG_CPE_ID:=cpe:/a:heinz_mauelshagen:lvm2
 
+PKG_BUILD_PARALLEL:=1
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libdevmapper
@@ -53,11 +55,11 @@ define Package/lvm2/description
 endef
 
 CONFIGURE_ARGS += \
-  --disable-o_direct \
-  --with-default-pid-dir=/var/run \
-  --with-default-dm-run-dir=/var/run \
-  --with-default-run-dir=/var/run/lvm \
-  --with-default-locking-dir=/var/lock/lvm
+       --disable-o_direct \
+       --with-default-pid-dir=/var/run \
+       --with-default-dm-run-dir=/var/run \
+       --with-default-run-dir=/var/run/lvm \
+       --with-default-locking-dir=/var/lock/lvm
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
diff --git a/utils/lvm2/patches/000-compile.patch b/utils/lvm2/patches/000-compile.patch
deleted file mode 100644 (file)
index 111a86e..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/make.tmpl.in
-+++ b/make.tmpl.in
-@@ -29,7 +29,7 @@ SHELL = @SHELL@
- # Allow environment to override any built-in default value for CC.
- # If there is a built-in default, CC is NOT set to @CC@ here.
--CC ?= @CC@
-+CC = @CC@
- # If $(CC) holds the usual built-in default value of 'cc' then replace it with
- # the configured value.
diff --git a/utils/lvm2/patches/001-include_fix.patch b/utils/lvm2/patches/001-include_fix.patch
deleted file mode 100644 (file)
index c209c0e..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/lib/device/dev-type.c
-+++ b/lib/device/dev-type.c
-@@ -25,7 +25,7 @@
- #include <ctype.h>
- #ifdef BLKID_WIPING_SUPPORT
--#include <blkid.h>
-+#include <blkid/blkid.h>
- #endif
- #ifdef UDEV_SYNC_SUPPORT
index d547c5f78bd01d2c5867714dc8343da303e1df84..1cc2b8f86ca9a523c6c16c5de7346006cb225e61 100644 (file)
@@ -1,6 +1,6 @@
 --- a/lib/commands/toolcontext.c
 +++ b/lib/commands/toolcontext.c
-@@ -1649,7 +1649,7 @@ struct cmd_context *create_toolcontext(unsigned is_clvmd,
+@@ -1599,7 +1599,7 @@ struct cmd_context *create_toolcontext(unsigned is_clvmd,
        /* FIXME Make this configurable? */
        reset_lvm_errno(1);
  
@@ -9,10 +9,10 @@
        /* Set in/out stream buffering before glibc */
        if (set_buffering
  #ifdef SYS_gettid
-@@ -2031,7 +2031,7 @@ void destroy_toolcontext(struct cmd_context *cmd)
-       if (cmd->libmem)
-               dm_pool_destroy(cmd->libmem);
+@@ -1980,7 +1980,7 @@ void destroy_toolcontext(struct cmd_context *cmd)
  
+       if (cmd->pending_delete_mem)
+               dm_pool_destroy(cmd->pending_delete_mem);
 -#ifndef VALGRIND_POOL
 +#if defined(__GLIBC__) && !defined(VALGRIND_POOL)
        if (cmd->linebuffer) {
@@ -20,7 +20,7 @@
                if (is_valid_fd(STDIN_FILENO) &&
 --- a/tools/lvmcmdline.c
 +++ b/tools/lvmcmdline.c
-@@ -3055,6 +3055,7 @@ int lvm_split(char *str, int *argc, char **argv, int max)
+@@ -3230,6 +3230,7 @@ int lvm_split(char *str, int *argc, char **argv, int max)
  /* Make sure we have always valid filedescriptors 0,1,2 */
  static int _check_standard_fds(void)
  {
@@ -28,7 +28,7 @@
        int err = is_valid_fd(STDERR_FILENO);
  
        if (!is_valid_fd(STDIN_FILENO) &&
-@@ -3081,6 +3082,12 @@ static int _check_standard_fds(void)
+@@ -3256,6 +3257,12 @@ static int _check_standard_fds(void)
                       strerror(errno));
                return 0;
        }
index 13682bf5843b723eacfb3e33c628cf99ed8d370d..2993a5a4600515208153c41087ba7dcddf19ed49 100644 (file)
@@ -15,7 +15,7 @@ on standard C libraries without O_DIRECT_SUPPORT.
 
 --- a/lib/device/dev-io.c
 +++ b/lib/device/dev-io.c
-@@ -564,7 +564,7 @@ int dev_open_flags(struct device *dev, int flags, int direct, int quiet)
+@@ -374,7 +374,7 @@ int dev_open_flags(struct device *dev, int flags, int direct, int quiet)
                return 0;
        }