add lm92 kernel module
authorJohn Crispin <john@openwrt.org>
Wed, 3 Apr 2013 10:00:40 +0000 (10:00 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 3 Apr 2013 10:00:40 +0000 (10:00 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 36181

package/kernel/modules/hwmon.mk

index d549336b3d0490e6d080e8e45c19d84e361ad8a1..bc1f65281da19b22f30e21ce5e2a180040a2f81e 100644 (file)
@@ -134,6 +134,20 @@ endef
 
 $(eval $(call KernelPackage,hwmon-lm90))
 
+define KernelPackage/hwmon-lm92
+  TITLE:=LM92 monitoring support
+  KCONFIG:=CONFIG_SENSORS_LM92
+  FILES:=$(LINUX_DIR)/drivers/hwmon/lm92.ko
+  AUTOLOAD:=$(call AutoLoad,60,lm92)
+  $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPackage/hwmon-lm92/description
+ Kernel module for LM92 thermal monitor chip
+endef
+
+$(eval $(call KernelPackage,hwmon-lm92))
+
 define KernelPackage/hwmon-lm95241
   TITLE:=LM95241 monitoring support
   KCONFIG:=CONFIG_SENSORS_LM95241