iftop: add package
authorPaul Spooren <mail@aparcar.org>
Wed, 9 Dec 2020 21:46:51 +0000 (11:46 -1000)
committerPaul Spooren <mail@aparcar.org>
Thu, 10 Dec 2020 09:36:29 +0000 (23:36 -1000)
Moved over from openwrt.git

Signed-off-by: Paul Spooren <mail@aparcar.org>
net/iftop/Makefile [new file with mode: 0644]

diff --git a/net/iftop/Makefile b/net/iftop/Makefile
new file mode 100644 (file)
index 0000000..8f5613c
--- /dev/null
@@ -0,0 +1,39 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=iftop
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://code.blinkace.com/pdw/iftop.git
+PKG_SOURCE_DATE:=2018-10-03
+PKG_SOURCE_VERSION:=77901c8c53e01359d83b8090aacfe62214658183
+PKG_MIRROR_HASH:=219231541a437f5aecd497796be0202d337e13f141359a93595bf2cd8c5c5544
+PKG_MAINTAINER:=Paul Spooren <mail@aparcar.org>
+PKG_LICENSE:=GPL-2.0
+
+PKG_FIXUP:=autoreconf
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/iftop
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+libpcap +libncurses +libpthread
+  TITLE:=display bandwith usage on an interface
+  URL:=http://www.ex-parrot.com/~pdw/iftop/
+endef
+
+define Package/iftop/description
+       iftop does for network usage what top(1) does for CPU usage. It
+       listens to network traffic on a named interface and displays a
+       table of current bandwidth usage by pairs of hosts. Handy for
+       answering the question 'why is our ADSL link so slow?'.
+endef
+
+define Package/iftop/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/iftop $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,iftop))
+